CNAME not propagating properly

My DNS settings have been confirmed to be correct by my hosting company, but CNAME is still not resolving. Getting message: This page isn’t working www.globalts-inc.com redirected you too many times. Site is hosted by Duda.co

Attached is DNS screenshot. Hostpapa is domain registrar. For some reason I cannot use their nameservers, which is why I’m using cloudflare nameservers. Domain is unlocked.
Any help would be greatly appreciated!

You’ve set that CNAME to :orange:, so it’s going to resolve as an “A” record for Cloudflare’s proxy servers.

The redirect loop is because it’s bouncing back and forth between HTTP and HTTPS. Was it working with HTTPS before you added it to Cloudflare?

No it was not working at all before I started using cloudflare.

Then you should get this working as quickly as possible on your server, otherwise the site will be insecure.

As for the CNAME, @sdayman’s explanation is spot on.

There is an SSL on the site now, provided by the hosting company.
Sorry, I’m not clear on what I need to do to resolve the CNAME issue? Thank you.

And that was not in place earlier?

As long as you proxy you will never have a CNAME. If you need a CNAME you need to toggle to :grey:

Okay thank you. I am only using cloudflare to manage my DNS settings and use their nameserevers, no other reason.
Should I just toggle off all the (orange cloudflare clouds) for it to function properly?

If you want Cloudflare only for DNS you can either toggle everything or pause Cloudflare altogether on the Overview screen.

I toggled all clouds off, and website is live now. Thank you for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.