Cname is not updating after hours

Hi, It’s been 5hours and my CName is still not updating. I don’t know why it’s not being resolved. My site name prorobloxguides .com

Welcome to the community! As I can see, dig doesn’t return any value when searching for CNAME records in prorobloxguides.com.

You may want to try 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver to purge 1.1.1.1’s DNS cache.

Hope it helps!

No use I did it and still didn’t work. This is my Cname

I can see the CNAME record when using DiG:

; <<>> DiG 9.16.27 <<>> @162.159.36.1 www.prorobloxguides.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31203
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www.prorobloxguides.com.       IN      A

;; ANSWER SECTION:
www.prorobloxguides.com. 300    IN      CNAME   prorobloxguides.com.
prorobloxguides.com.    300     IN      A       35.236.48.6

;; Query time: 172 msec
;; SERVER: 162.159.36.1#53(162.159.36.1)
;; WHEN: Sat Sep 03 1

You may need to restart your browser, or even your device, to flush the local DNS cache.

If it’s fixed then is the site prorobloxguides. com loading? please send screenshot if so.

Here is a quick video of the result:

But it takes you to non www. version if you check the URL after the site is loaded. I want everyone to visit www version not non www. version

Then I would suggest that you use an A record with your server’s IP address for the www subdomain, instead of a CNAME one. Then, on the server side, you can configure it to redirect non-www to www.

Also, you can also change than CNAME to an A record, proxy (:grey::orange:) your root domain and setup a redirection rule on Cloudflare Page Rules. You may also need to enable Universal SSL, if you haven’t already, for this to work with HTTPS.

Hope it helps!

1 Like

That change is not necessary. The following is the important part.

The redirection can even be performed at Cloudflare rather than the origin server if you prefer, but it does need to happen somewhere so that traffic using the apex name is redirected to the www alias. The origin server also needs to know that it should serve content when www is the requested hostname.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.