CNAME Flattening & Smugmug Domains

dash-dns
#1

Hey there! I recently switched my nameservers to use CloudFlare for DNS management on my domain, monochromatic.co. I use the domain for a G Suite email address, as well as the domain for my photography portfolio which is hosted on smugmug. I set my CloudFlare account up a week or so ago and everything was running fine.

However, last night I got an email from smugmug saying my custom domain wasn’t resolving anymore. To use a custom domain with smugmug, you only need to add a CNAME record to point at domains.smugmug.com. I had done so, and everything was working as intended.

However, now it’s not resolving for me. I see the little notice directing me to a help article regarding CNAME flattening, but I don’t really understand it. I assume this is what’s preventing it from resolving properly. How can I fix this?

#2

Is the CNAME supposed to be on the root domain? If they need to see it they won’t be able to do so:

  1. CNAMEs aren’t supported at root by the DNS spec. Cloudflare will allow it and return insted the remote IP directly.
  2. You would have to disable proxying for them to see it in the first place (apart from case 1.), click on :orange: and turn it into :grey:.
#3

Sorry for the slow response. I’m not sure if it needs to be the root domain or not. Here’s there’s guide on the matter. It’s just odd to me that I had everything connected fine for the first few days while using CloudFlare, and I’m not sure what changed.

Right now, I’ve only got an A Record, this CNAME record, and 5 MX records for my google suite email.

#4

In theory reading the guide you would need to put a CNAME from www to domains.smugmug.com, then do a redirect or a CNAME from the root to www. Will explain the solution later. No other records (except for MX should exist regarding this). I don’t know where the A record is though, so may be needed for other services.

You can do a CNAME from @ to www.monochromatic.co (may not work) or add a record there to a random IP (use 192.2.0.1 which is a not assigned one), proxy it and add a page rule to redirect from the root to www. If you need help with this ask.

I suspect the CNAME for www doesn’t have to be proxied since the will maybe not see it and give an error, but try both ways.

#5

Okay, I removed the A record since I also did not know what it was for. I changed my CNAME record to have the name “www” and the value of " domains.smugmug.com". That’s the only CNAME record I have. I tried to add one from root to www, but wasn’t able to. Same with @ to monochromatic.co.

Does this seem like it’ll work? I’m still waiting for it to propagate of course.

#6

Here’s a screenshot of my entire DNS panel as it stands right now, by the way.

#7

You need to out in the the whole domain name, so from @ to www.monochromatic.com.

@ means the root, so you were trying to add a CNAME from root to itself.

Propagation is basically instant, it works for me. It’s redirecting you to their subdomain.

#8

Okay, I added that.

It’s still not resolving correctly for me, but should it now with these two CNAME records?

#9

For me it works fine, maybe try clearing your cache in the browser?

#10

Right now, the naked domain monochromatic.co doesn’t resolve to anything. If I go to www.monochromatic.co, it resolves to my smugmug url, which is monochromatic.smugmug.com.

My intention, which is how it was working before, is to have monochromatic.co go to the domain, and for all the categories to work off of that link, rather than the smugmug link.

Is that how it’s working for you?

#11

Everything goes to the smugmug.com subdomain, but that is something you need to configure on their end.

1 Like
#12

I don’t think so. It wasn’t on a subdomain under smugmug before. I’m not sure what changed. I was having issues with my MX records at my registrar, so I redirected my nameservers to CloudFlare, but before I just had a CNAME record with the name @ pointing to domains.smugmug.com and worked as intended. I’m not sure why I’m running into trouble now.

#13

Try disabling the proxying to both records. Click on :orange:, will turn into :grey:.

#14

Got it, switched them both to grey.

closed #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.