Hi All

I seem to have an issue all of the sudden with my cloudfare subdomains not rezolving …

any input is greatly appreciated.

C:\Users\bozan>nslookup c***
Server: pihole.main.lan

Name: c*
Address: 92.

this is expected … even if proxy mode is turnerd on.

C:\Users\bozan>nslookup c***

Name: c***

But as soon as I try a subdomain …

C:\Users\bozan>nslookup auth.c***

*** can’t find auth.c*** Non-existent domain

But then I get a return using the name server assigned to the domain …

C:\Users\bozan>nslookup auth.c***

Name: auth.***.eu
Addresses: 2606:4700:3035::6815:3296

So how is this possible ? does not see the records of aleena ?

I have some 13 subdomains asigned to forward to the main domain but they don`t …

What’s the domain?

That domain is currently not using Cloudflare in the first place.

nslookup -type=ns
Server:  UnKnown
Address:        nameserver =        nameserver =

Also, it would appear as if you had an invalid certificate on your server. You definitely need to fix that as well.

And I guess you should double check your DNSSEC entries on your registrar’s side and make sure those are properly configured.

Hi mate …

This was fully working for about 2 weeks with cloudfare …

When I log into my cloudfare account the domain is shown into cloudfare and the two name servers are and

I have 13 cnames assigned which were all working till 2 days before …

The domain is registered with however the dns is handled by cloudfare unless something happened that I don’t know off …

It looks like something happened:

Then you need to talk to your registrar as the nameservers obviously changed.

Plus, the other issues.

Well this is odd !

But if you nslookup the domains with it returns what I posted initially which is a proxy in cloudfare network …

How is this possible ?

Also in my account under DNS tab it shows that points to my servers address.

I’m kinda stuck here …

At this point it is not relevant what Cloudflare returns as they are not your authoritative nameservers. You need to change that at your registrar, along with fixing the other issues.

Right so I need to go back into 123 and check the NS.

Ok got it … let me see…

Make sure you’re working on the WHOIS data and not a DNS record entry “NS”.

Right … this is odd as I never changed these after setting up the cloudfare ones… Never thought of these changing by themselves ?

The nameservers are correct now, but you still have an invalid SSL setup on your server. You need to fix that too.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.