CNAME do not update

We have CNAME record trueplay.io, which was pointed to the https://d1yldeewrzwg1t.cloudfront.net for a long time (it’s root domain and it’s automatically flattened). It was proxied through the Cloudflare.

We have changed CNAME to point to the d396immk7rp2dc.cloudfront.net, but it didn’t change pointed location for 3 days. We tried saving it few times, turning off proxying, but it do not updates. For now we changed to DNS only and wait if it will help.

Cloudflare cache was cleared few times, tried changing ssl/tls options, but didn’t help.
#dns #reliability #bug #caching #cache

Any suggestions?

We changed back to the proxied, because DNS only didn’t help. (waited for 2 days)

Solution:

The problem was that AWS Console somehow allowed us to create CloudFront distribution with the same domain as alias domain in another AWS account. So after deleting that distribution and recreating in new account and updating Cloudflare CNAME record it updated immediately.

PS.
First reply from Cloudflare support was in 4 days after ticket was created. Then 1 reply in 24 hours.

So the problem was with AWS then? What was their support response time?