Cname DNS Setup

dns
cname

#1

I need help cname setup


#2

The place hosting your site should have some instructions on what CNAME to use to point to their server.

What have you tried so far?


#3

I need cname cloudflare dns
ii try https://support.cloudflare.com/hc/en-us/articles/200168706-How-do-I-do-CNAME-setup-


#4

I’m attaching a typical way to add a CNAME here. You will need to know the destination host. THAT host will know that if they see a request for your website, they will respond with the correct content. But they have to let you know what you need to point your CNAME to. In my example, the @ entry stands for example.com (your website), and mydomain.hostsite.com is what your host tells you to input. You should do another entry for “www” that points to the same place.


#5

I am not completely sure that this is what he wants. He is trying to configure the CNAME DNS setup for his whole domain. Don’t know how to help as I have never tried it.

@kuzeyakaba you need to have a plan at the Business or Enterprise level, which are paid products. If you need any help (in addition to the step-by-step guide on the link you posted), at these plans, your best bet would be support that has access to your account and can assist you directly with priority.


#6

And how contact with support


#7

On the top right of your dashboard there is a link to support.cloudflare.com, otherwise you can e-mail them (from the e-mail used in the account) at support AT cloudflare DOT com


#8

Really i try is add ssl in my sub domain but I do not know what’s happening
Why my site look this picture:

1

why


#9

You need to set your www (and possibly the root) subdomain to :orange:, that will fix the issue.

You could also consider, if it is possible, installing a Cloudflare Origin certificate instead of the currently self-signed one so that you are able to set SSL to Full (Strict),


#10

how


#11

Click on the :grey: clouds.


#12

okay what next


#13

All set!


#14

yes i think


#15

Yep, you need to set also Always Use HTTPS in the Crypto tab, forgot about that… Otherwise it will default to HTTP.


#16


Okay what next


#17

For a basic HTTPS setup you are all set, maybe enable Automatic HTTPS rewrites, but not strictly necessary although helpful.


#18

Yes work in main domain but in sub domain is very very rare
look this

Captura


#19

That is because there are issues in the page, usually mixed content errors. That can be fixed by using HTTPS on every source or link (not external links, but resources) of the page, by using the Automatic HTTPS Rewrites or a CSP (this becoming technical)


#20

haha, yes is very helpful thank for help, wait 1 min pls