CNAME DNS Record not working

Summary :
CNAME DNS Record not working

Error Report / Description:

Dear Cloudfront team,

I’m trying to set up additional CNAME records for the domain cleanstart-consulting.com:

CNAME “read.cleanstart-consulting.com” with value “ghs.googlehosted.com
CNAME “dhv3xq67eyjg.cleanstart-consulting.com” with value “gv-worpzxhc5prscv.dv.googlehosted.com

I have added both CNAME records to the DNS configuration section in my Cloudfront admin, and let some time pass to make sure the changes take effect.

However, the CNAME records are not yet available, as you can see here:

Can you advise on what might be wrong here?

Kind Regards

We’re not Cloudfront. Maybe you’re thinking Route 53, also an Amazon service.

1 Like

Hi Sdayman,
Thank you for the response. Sorry, I copied and pasted what the tech guy from Magloft wanted me to ask you, and he got Cloudflare name wrong.
Yes, I do still need help with this answer. So, please review again how I can get the TTL to their (Magloft’s) required 3600. I can’t change from the automatic, and it’s not working.
Magloft is working on my PWA (progressive web application) for my online magazine, CleanStarter Magazgine at Cleanstart Consulting. Thank you!

Two ideas:

  1. I don’t know why they insist on a TTL of 3600. The auto TTL of 300 should be fine.
  2. It’s possible they can’t work with a :orange: Proxied CNAME, so you’d have to set it to :grey: DNS Only. On the upside, this will also let you set your TTL to one hour.
1 Like

So, the tech guy from Magloft sent me this after I sent your response to him last night.

"Hi Rosalynn,

I did some more research and found that your setup with CloudFlare might require the DNS records to be set up both in cloudflare (using CNAME records as we’ve done previously), as well as GoDaddy (equivalent CNAME records).

Can you try setting up all four CNAME records (2x cloudflare, 2x godaddy) and let me know once this is done?"

But when I spoke with GoDaddy they said they cannot do anything with DNS because it’s all in CloudFlare. I understand GoDaddy only hosts my website.

I am so confused.

They are looking for the specific values to exist @rosalynn so the records need to be DNS only not proxied.

1 Like

Okay, so when I try putting it in DNS Only. I don’t have a place to paste the above info (first post) where I tried. Let me attach the photos I sent the IT guy on here so you can tell me what I’m doing wrong. I just saw I can attach photos on here. Can you direct me please, to the place I need to fill out the info they gave me so it works? Thank you so so much!

These are the tasks I’m being asked to do. Thank you!

Click the existing CNAME record. There is a field which is :orange: / Proxied. Click the cloud so it turns :grey: and click save.

2 Likes

Oh, my goodness it was that easy! Thank you!! I know it will take some time, so I’ll wait and touch base with the IT guy late tonight, a morning where they are based. Thank you! Hopefully this is all that is needed.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.