CNAME Cross-User Banned problems

i can’t write nothing here or this website don’t let me make this topic cause it say “new user can only post 4 links for topic” Yhea, sad im not posting a single link, embarassing.

Have a problem with this. i created a subdomain for my gitbook and don’t work giving this error to me. any help?

Gitbook recommends disabling Cloudflare’s proxy for your Gitbook DNS record ( :orange: to :grey:).
Once you’ve disabled the proxy, it should work after ~5-10 minutes once your DNS cache has expired.

Are you using Cloudflare?

If you are configuring DNS in Cloudflare’s control panel, you may be tempted to activate Cloudflare’s proxying (the orange cloud, also called “Proxy status” in your domain settings).

While this configuration might work in most cases, we strongly recommend against activating it. Firstly, because your custom domain will already benefit from Cloudflare’s CDN and a Google Trust Services SSL certificate on our end. Secondly, this option obfuscates the DNS target for your domain to the public, preventing GitBook to properly run routine checks on your custom domain.

Whenever possible, please turn off Cloudflare proxying to ensure that your documentation is served without issues and can be monitored by GitBook.


Hmmm no, is not this the spolution. i’ve already do this, waiting by yesterday and still have that error. i installed my cname on Cloudflare dns without the orange cloud actived, so with no proxy option. i also retried to delete the cname record for then remade it and nothing, still get the error…

In that case, I would recommend double-checking that you’ve configured the right custom domain at gitbook. If the custom domain name hasn’t been configured correctly, then it can also cause these “CNAME cross-user” errors.

1 Like

Hello, everything is setup correctly… CNAME, docs and the url of my gitbook page… then save… without orange clouds… is a very simple things… dunno why it doesn’t work…

Hey, this time i have deleted the CNAME, waited a couple of hours for a total dns flush, add it back and now work! very weird! thanks too for your help!