CNAME added to DNS is not validating on Azure

We got

  1. Static site on Azure cloud
  2. Google is the domain provider
  3. Cloudflare Nameservers

What we’re trying to achieve

Publish a static site with own domain name - that requires the Custom Domain name to be added in Azure Portal which basically maps the domain using DNS record. In our case we are trying to add CNAME record to DNS in Cloudflare.

Issue

The CNAME is not validating on Azure Portal. The error says “CNAME Record is invalid. Please ensure the CNAME record has been created.”

Analysis

  • We checked whether DNS entries are populated or not and it turns out that TXT & A record are working fine but CNAME record is not showing up. It’s been a substantial amount of time since the last DNS change

  • We used “whatsmydns .net”

  • CNAME only causing the problem and it’s not related to Azure cloud but with Cloudflare itself.

  • to add - when we tried to make the CNAME record ‘DNS only’ then it worked. Proxied CNAME record is not working.

Resolution or workaround would be most appreciated

Thanks!

Hello there,

If A record is working fine, why don’t you add A record instead of CNAME while its not added.

Correct. Proxied CNAME will not work. When a CNAME is proxied in Cloudflare DNS, an A and AAAA record pointing to Cloudflare are published instead of a CNAME record. Any third-party services that require a CNAME record to be published must use :grey: DNS Only.

1 Like

that’s because A record requires IP address and Azure Static Site do not provide public ip, instead we get a URL, left with ALIAS / CNAME as the only two options to add in DNS.

with DNS only we lose the Cloudflare feature that optimize, cache, and protect all our requests.

is there any way to bypass it? or any workaround?

As long as the service you are using requires a published CNAME record, you will not be able to use the proxy. You will need to check with the third party to see if they provide another means of validation.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.