Cloudways, Cloudflare, CDNs, and LetsEncrypt

Hi, I have a wordpress site (stephensessions.com) hosted on Cloudways with a Digital Ocean droplet. I’m having a terrible time getting it to work with Cloudflare.

My domain registrar is Cloudflare, and I have two CNAME subdomains for testing.

I’ve enabled a LetsEncrypt SSL Certificate thru Cloudways, but not their CDN.

Cloudflare Crypto is set to off, and Universal SSL is Disabled.

What is the best way to setup Cloudways and Cloudflare using a LetsEncrypt SSL? For a while I had my main site working but not the subdomains, but now nothing is working.

I simply want a wordpress site to work with the LetsEncypt SSL and Cloudflare CDN. I have no idea what’s wrong.

If you set the SSL on Cloudflare to Off, then you will just be loading the site over HTTP and may get redirect errors if you already have a certificate on the server.

To make your site secure, you should keep the Let’s encrypt certificate and set the SSL mode to Full (strict).

I’ve set it to Full (strict) and my site is still down.

What should my optimal settings be for using cloudflare and cloudways?

Are you able to post a screenshot of your crypto tab in Cloudflare?

Crypto page:

1 Like

You will need to click the 'Enable Universal SSL` option at the bottom and wait for the certificate to issue.

Hello @stephensessions, it’s Mustaasam from Cloudways.

You may need to follow these steps:

  1. Disable Cloudflare
  2. Install WordPress SSL certificate on your website.
  3. Choose Cloudflare under WAS Module by going to Settings and Packages -> Advanced in the Cloudways platform.
  4. Go back to Cloudflare and set SSL to Flexible under Crypto.
  5. Once the certificate is activated, switch it to Full (strict).
  6. Enable Cloudflare.

For more details, have a look at our Cloudflare WordPress guide.

1 Like

Hello @mustaasam.gt

Thanks, I’ve followed your directions and my main site is now working.

I’m still trying to get my subdomains to work.

I have two apps on Cloudways that I’d like to be subdomains. Does each app need it’s own Let’sEncrypt SSL Certificate using the subdomain?

Thanks.

@mustaasam.gt Here are my DNS settings:

How should I set the ‘domain management’ settings in Cloudways?

Hello @stephensessions yes, you need to add subdomains in Domain Management tab.

Go to the Domain Management of your respective apps and add subdomains (sub.example.com)

For the DNS part, you need to add one more A record for all the subdomains:

Thanks! Subdomains are working, but they are not secure (https). I have SSL certificates on each app.

@stephensessions Have you tried accessing with HTTPs manually? Can you please share the subdomain URLs?

when I manually type in https://dev.stephensessions.com/, it works, but dev.stephensessions.com does not.

How do I force http to https?

That host is not proxied, hence any Cloudflare settings wont take effect. You need to talk to your host about that.

Alternatively, proxy it and make sure “Always use HTTPS” is on.

Looks like you only need to force HTTP to HTTPs. Try adding below code at the beginning for your .htaccess file:

RewriteEngine On
RewriteCond %{http:X-Forwarded-Proto} !HTTPS
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

Reference: https://www.cloudways.com/blog/add-free-ssl-certificate-to-wordpress-websites/#redirect-http-to-https-via-wordpress-htaccess-file

This topic was automatically closed after 31 days. New replies are no longer allowed.