Cloudflare's Development Mode is broken

Sometime in the last 24 hours, it appears that Cloudflare’s Development Mode stopped working correctly.

Usually, when Development Mode is active, Cloudflare won’t cache new changes to CSS files, which means that you can easily refresh (or Ctrl+Shift+R) during development while making changes to see the latest version.

Right now, though, something is amiss and we’re having to manually click “Purge Everything” after every single change even though Development Mode is enabled.

Has there been some kind of change on the backend? Some experimental new feature?

On which URL can you reproduce that?

It’s on a client’s private site, so I unfortunately can’t share a URL.

It uses WordPress but doesn’t have any performance plugins installed and the Cloudflare DevMode + Ctrl+Shift+R method has worked fine for years. Something has changed since this same time yesterday and it wasn’t on our end.

I tried it on Chrome, Firefox, and an older version of Chrome to make sure that it wasn’t some kind of browser bug. Clicking “Purge Everything” fixes it for one single reload, so it’s definitely on Cloudflare’s end.

I’ve temporarily resorted to using a time-based cache-busting string in all of the asset URLs, which is horribly inefficient but the only way that we can develop right now.

In that case it’s not possible to provide specific advice, but development mode should work in the same way it always did. IIRC, you should purge the cache once, but once you have done that, nothing new should be cached as long as that mode is enabled.

Maybe you have a browser issue, try different browsers. You can also check Cloudflare caching status, you should never get a HIT.

1 Like

Just left another reply about that. We’ve ruled out everything besides Cloudflare at this point.

Well, I just double checked and development mode works exactly as it is supposed to. So that won’t be a Cloudflare issue. As I said you can also verify the other steps I mentioned.

You can easily verify this yourself. Check out the cacheable files on sitemeer.com and you will notice that nothing is being cached.

I don’t understand what you mean about sitemeer.com.

The problem is that it’s caching our CSS and JS files even while Development Mode is active and we’re having to manually hit “Purge Everything” and wait 30 seconds after every single change. That’s not normally the case. Something has changed.

What is unclear about this sentence?

Just as an example

image

Just for your information, I will deactivate development mode in a couple of minutes again, which means it will then cache again.

image
image

Here’s what the response header looks like for our assets right now.

I’m not really familiar with the headers but I assume that “Hit” means that it’s serving a cached copy even though Dev Mode is enabled?

That is correct, that entry indicates it was cached only a couple of seconds ago.

Are you sure you are configuring the right Cloudflare account? Is the DNS record in question actually :orange:?

I cleared it again a few seconds ago just to make sure it would show the right header. And yeah, we have orange clouds like we usually do. Nothing has been changed there in months, if not years.

It’s definitely the right account as well. Again, we can manually clear the cache by hitting “Purge Everything”, but that’s been unnecessary for the last three years while having Dev Mode active.

Our usually workflow is to enable Dev Mode, click Purge Everything once, and then make our changes to the themes/plugins easily for the next three hours. Right now, we’re having to hit Purge Everything after every single change or else the CSS/JS files will remain unchanged. Ctrl+Shift+R isn’t doing anything and we even tested an older backup of the site as well as several different browsers but to no avail.

I am sorry, without the domain it is not possible to provider further advice. All the evidence does seem to suggest that development mode is working fine, so it’s either something with your configuration or where you configure it. I can only suggest to double check everything and make sure you are configuring the right account and that your changes are applied.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.