Cloudflared unable to reach origin

Any updates? I’m also getting the following error:

ERR error=“Unable to reach the origin service. The service may be down or it may not be responding to traffic from cloudflared: EOF” cfRay=73ffc3728f8d2ba7-ORD

How are you running cloudflared? Windows, Linux, docker?
What is your config?
How did you set up your config? YAML file or via dashboard?
Does the URL respond when manually checked from the device where cloudflared is running from?

Running Cloudflared via docker on Unraid.
Cloudflared version 2022.8.2
Config was setup via yaml.
Config:
tunnel:
credentials-file: /home/nonroot/.cloudflared/.json

NOTE: You should only have one ingress tag, so if you uncomment one block comment the others

forward all traffic to Reverse Proxy w/ SSL

ingress:

  • service: reverse proxy ip goes here
    originRequest:
    originServerName:

#forward all traffic to Reverse Proxy w/ SSL and no TLS Verify
#ingress:

- service:

originRequest:

noTLSVerify: true

forward all traffic to reverse proxy over

#ingress:

- service: reverse proxy example goes here

According to the logs on Cloudflared, it doesn’t have an issue reaching Cloudflare.

I am cursed with having Xfinity as my ISP with where I’m staying and can’t get any ports opened up. Idk if that will have anything to do with the problem or not.

This won’t be a problem. The main purpose of tunnels is providing a way to access internal resources without needing to open ports.


It looks like you are using this setup

Your config should look something like

tunnel: <tunnel id>
credentials-file: /home/nonroot/.cloudflared/<tunnel id>.json


# forward all traffic to reverse proxy over http
ingress:
  - service: http://<unraid-home>

I would look into configuring the tunnel via the dashboard because you’d be able to just run a single docker command and be able to update the tunnel via the web UI and not the YAML file.

I’ll give it another go later this evening and post back here with the results.

Doing all of that still gives me the same result. Before I removed the old tunnel and created the new one, it was showing as connected on the dashboard. Made the new one, it also showed as being connected. But would still get that same error. So I’ve no idea what I’m doing wrong but I’m doing something wrong somewhere.

Can you share your docker config? For accessing host ports from a docker container, you need to make sure that you include --add-host=host.docker.internal:host-gateway and point all connections to host.docker.internal to reach the host container.

I have no idea on how to do that with Unraid. There’s still a LOT that I’m learning with it.

I should also mention that I have very rudimentary knowledge/experience with anything Linux.

At this point, I can’t really help you. I haven’t used unraid before, so I don’t know what the setup and configuration looks like on that side. Your best bet is to google some more guides and figure out how other people have done it. It doesn’t seem to be a Cloudflare issue and more of a misconfiguration issue on other platforms.

1 Like

I appreciate you taking the time to try and help me troubleshoot this. Many thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.