Cloudflared tunnel works only on my android phone

Hi, could someone help me please.
I tried everything I could, but now I’m helpless.

I set up cloudflared tunnel on my raspberry pi.
I can connect to my home network on my android phone without problem, but from my Windows 10 laptop I can reach only my home router.
It works from my laptop if I connect to my phone’s hotspot.

Thank you

What error are you getting? It sounds like there might be a DNS issue from your home network.

I now tried to connect from a different outside router/network and the behavior is the same. On my home router I am running openwrt. Could that be the reason? How could I see if there are some errors? Thanks.

And earlier I saw on my router home page, that my laptop got a DHCP lease, but my phone wasn’t there. Or was it the other way around?

scratch that. I don’t see neither of those. any guesses?

ok, so my laptop gets a dhcp lease on my home router and can access only home router. My android phone doesn’t get a dhcp lease on my home router, but can access my whole home network. Any ideas where should I look? thanks