Cloudflared tunnel cannot connect to cloudflare

Yesterday I had the same issue (I think it was only coincidence but it began after cloudflare downtime).

Updating the DNS records fixed it, although there was nothing wrong with them in the first place.

Now I’m getting the same issue but I can’t resolve it and decided that I shouldn’t treat editing the DNS records as a solution, because that guarantees downtime.

I have cloudflared set up following the usual CLI setup guide, with the cloudflared service installed.

When I run systemctl start cloudflared, it just hangs.

When I cancel starting the service with Ctrl+C, then issue systemctl status cloudflared, I see the following logs:

Unable to establish connection with Cloudflare edge error="DialContext error: dial tcp [...]:78>
12T07:07:02Z ERR Serve tunnel error error="DialContext error: dial tcp [...]:7844: connect: network is unreachable"  connIndex=0 event=0 ip=...::4
12T07:07:02Z INF Retrying connection in up to 1m4s connIndex=0 event=0 ip=...::4