Cloudflared reached the Cloudflare edge, but there was an unknown error registering the connection

Hi,

 I had installed Cloudflared in W:\ and created the tunnel. My config (YML) file, cert.pem are placed in C:\Users\ABC\.clouflared.

I run the following command in my powershell.
PS W:\Cloudflared\20210420> .\cloudflared.exe tunnel run ao-changecontrol-api
.\cloudflared.exe : 2021-04-26T13:50:56Z INF Starting tunnel tunnelID=3f0e1954-7bc0-4a12-a8cf-893e6697ae80
At line:1 char:1

  • .\cloudflared.exe tunnel run ao-changecontrol-api
  •   + CategoryInfo          : NotSpecified: (2021-04-26T13:5...cf-893e6697ae80:String) [], RemoteException
      + FullyQualifiedErrorId : NativeCommandError
    
    

2021-04-26T13:50:56Z INF Version 2021.4.0
2021-04-26T13:50:56Z INF GOOS: windows, GOVersion: go1.15.7, GoArch: amd64
2021-04-26T13:50:56Z INF Settings: map[cred-file:C:\Users\ChinnaduraiA.cloudflared\3f0e1954-7bc0-4a12-a8cf-893e6697ae80.json
credentials-file:C:\Users\ChinnaduraiA.cloudflared\3f0e1954-7bc0-4a12-a8cf-893e6697ae80.json hostname:gbbl1itvmsr01]
2021-04-26T13:50:56Z INF cloudflared will not automatically update on Windows systems.
2021-04-26T13:50:56Z WRN The property hostname in your configuration is ignored because you configured a Named Tunnel in the property tunnel. Make
sure to provision the routing (e.g. via cloudflared tunnel route) or else your origin will not be reachable. You should remove the hostname
property to avoid this warning.
2021-04-26T13:50:56Z INF Generated Connector ID: 1c255a6f-0aaf-45e6-8c80-044374c889bd
2021-04-26T13:50:56Z INF Initial protocol h2mux
2021-04-26T13:50:56Z INF Starting metrics server on 127.0.0.1:63869/metrics
2021-04-26T13:50:56Z INF cloudflared does not support loading the system root certificate pool on Windows. Please use --origin-ca-pool to
specify the path to the certificate pool
2021-04-26T13:50:59Z INF Connection f83103dd-a943-462b-a8c3-ade732ac02a9 registered connIndex=0 location=AMS
2021-04-26T13:51:00Z INF Connection cd2baded-fcbd-4561-b4f9-4df191b907e4 registered connIndex=2 location=AMS
2021-04-26T13:51:01Z INF Connection 8494cc86-645b-4062-a7cf-54de95994a68 registered connIndex=3 location=CDG
2021-04-26T13:51:03Z ERR Register tunnel error from server side error=“Cloudflared reached the Cloudflare edge, but there was an unknown error
registering the connection” connIndex=1
2021-04-26T13:51:06Z ERR Connection terminated error=“Cloudflared reached the Cloudflare edge, but there was an unknown error registering the
connection” connIndex=1
2021-04-26T13:51:16Z INF Connection a00ae3de-9c05-4a5a-98cb-765240248f6c registered connIndex=1 location=CDG

Also attached the image.

Much apreciate, how to resolved the above error and proceed as it is show stopping one of our critical apps.

Hello,

That is not a fatal error. The connection reconnects right after, and the tunnel is operational. cloudflared is designed to be resilient to this sort of flaky errors

Are you observing any issue when accessing the hostname of the tunnel? (remember that you must route it https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/routing-to-tunnel/dns )

Hi CF Team,

            I had done DNS CNAME record and I didn't need Load balancer. so, after that when I start my tunnel by running a command and went to browser and type the DNS CNAME as www.abc.com, it doesn't work it says page not found.

So far…I have done…the following…
created the tunnel
created DNS CNAME
Tried to run the tunnel.

cert.pem and config files are exists in C:\Users~.Cloudflared* and also in C:\Windows\System32\config\systemprofile.cloudflared.

config file looks like below which is in C:\Windows\System32\config\systemprofile.cloudflared.
hostname: sampletest.devops.xyz.com
url: http://localhost:8150
logfile: L:\Logs\cloudflared.log
origincert: C:\Cloudflared\cert.pem

config file which is in
tunnel: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
credentials-file: C:\Users\xyz.cloudflared\XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXae80.json

hostname: abcabcabcabc01
service: https://localhost:8140

DNS set up PS W:\Cloudflared\20210420> .\cloudflared.exe tunnel route dns testchange-api www.testchange.com
2021-04-27T12:00:25Z INF Added CNAME www.testchange.com which will route to this tunnel tunnelID=3f0e1231-7dd0-4v1
2-a8cf-893e6697ae80

PS W:\Cloudflared\20210420> .\cloudflared.exe tunnel run testchangel-api

but still my service(www.testchange.com)is not working…appreciate where It went wrong… Is it in config file?. Please help to resolve this.