Cloudflared fails to create free tunnels

For example

$ cloudflared tunnel --url [http://localhost:3000](http://localhost:3000/)

2021-07-22T11:17:47Z INF Version 2021.7.0
2021-07-22T11:17:47Z INF GOOS: darwin, GOVersion: go1.16.5, GoArch: amd64
2021-07-22T11:17:47Z INF Settings: map[url:[http://localhost:3000](http://localhost:3000/)]
2021-07-22T11:17:47Z INF cloudflared will not automatically update when run from the shell. To enable auto-updates, run cloudflared as a service:
2021-07-22T11:17:47Z INF Initial protocol h2mux
2021-07-22T11:17:47Z INF Starting metrics server on
2021-07-22T11:17:47Z INF Connection established connIndex=0 location=AMS

and this is where it seems to hang, it doesn’t provide the tunnel URL. I’ve tried switching networks and restarting my system but it didn’t help. I had already created 3 or 4 tunnels earlier today with the same command, but now it’s not working anymore. Is this just happening for me?

I think there was some markdown conversion magic when I copy-pasted this, and apparently I can’t edit my post… anyway, the command i run is

$ cloudflared tunnel --url http://localhost:3000/

Didn’t do anything and now it’s working again :man_shrugging:t2: