*.cloudflareaccess.com redirected you too many times. To fix this issue, try clearing your cookies. ERR_TOO_MANY_REDIRECTS

Team is not longer able to login to team account on WARP client OR able to access application behind Cloudflare access. After successful AUTH it is taking user in infinite redirect loop.

It was working fine before when we only had Onetime token as authenticator. We noticed this error after adding Google Workspace authenticator. There also it was working fine for few hours, it stopped working from next day.

Not sure which configuration went wrong. We tried to removing new changes (removed Google workspace authenticator). But issue is still there.

We are facing same problem on Application access, after successful auth on access page, user goes into infinite redirect. It was working fine before Google Workspace authenticator changes.

  • https://.cloudflareaccess.com/warp > https://.cloudflareaccess.com/cdn-cgi/access/login/*.cloudflareaccess.com?kid=
  • https://.cloudflareaccess.com/cdn-cgi/access/login/.cloudflareaccess.com?kid= > https://*.cloudflareaccess.com/cdn-cgi/access/authorized?nonce=
  • https://.cloudflareaccess.com/cdn-cgi/access/authorized?nonce= > https://.cloudflareaccess.com/warp
  • https://.cloudflareaccess.com/warp > https://.cloudflareaccess.com/cdn-cgi/access/login/*.cloudflareaccess.com?kid=

We already tried following:

Cleared our cookies
Tried in incognito

Having the same issues with a custom PHP project @ mafiasource.nl/admin when auth is complete everything works fine (access to /admin works but only after auth and manual browsing to /admin) but the initial redirection just after authentication also ends up in an ‘redirect too many times’ error.

Hope anyone has any clues, thanks!

The errors “The page isn’t redirecting properly” or “ERR_TOO_MANY_REDIRECTS” indicates a redirect loop between Cloudflare and your origin server. The easiest fix for this is to remove the redirect on your origin server. For a more detailed set of options, review the troubleshooting suggestions in this Community Tip. Let us know if you continue to see issues after trying the Quick Fix Ideas in the Tip, we’re happy to help further.


@cloonan Thank you so much for reply.
My issue is not related to access my webapp url / origin server.

I am facing the infinite redirect loop when try to login into Team account on WARP client. To minimize the possibility I enabled the PIN authentication to login to Cloudflare access team account (Cloudflare zero trust account). But facing infinite redirect.
As soon as I enter valid PIN on WARP client it goes into ERR_TOO_MANY_REDIRECTS.

Only way I am able to by pass this issue is by changing the team URL. I wanted to avoid this as much as possible. The issue persisted across different devices so I do not think it may be related to permanent redirect or SO.

I had the same issue and found the only way to fix it was to right-click in Chrome, use Inspect, go to the Application tab, Storage sidebar option, then Clear site data button. That would let me log back in. Doesn’t explain why I’m losing registration so often and being asked to log in though…

I can no be sure. But did you check the session time set for CF application in CF access ? If it is small you could face the same issue. Or. It can be related to short application token/session

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.