Cloudflare Zero Trust DNS Filter

Hello everyone! I’ve created a free tier (currently) for the Zero Trust service. I am going to use it as a DNS filter/firewall for all my home traffic.
I’ve created “DNS Locations”, and set primary and secondary DNS in my router as instructed (also, tried to set it in /etc/reslov.conf). Then, I created “Firewall policies” DNS rule to filter (block) some applications, content categories, and domains.

It had worked fine, blocking some resources I listed until it just stopped filer traffic (DNS).

Can somebody tell me the reason why it doesn’t work? Maybe, the free tier doesn’t support DNS filtering (Firewall), or I didn’t set up all things around?

You can use DNS Firewall policies on free without any issue.

If it worked and randomly stopped, perhaps you have a dynamic IP which changed? When you create a location, you add your current IP as the Source IPv4 Address. If your IP changed and you are using the IPv4 DNS Addresses, Cloudflare no longer knows what account to associate your queries with.

IPv6, DNS over TLS (DoT), and DNS over HTTPS (DoH) DNS endpoints are unique to your location and do not require source IP addresses.

If your devices support it, I would use DoT or DoH

Thank you for your replay. I have a static IP address from my Internet provider, it hasn’t been changing since I set it.