Cloudflare zero trust bypass problem


I have a filebrowser on the domain to access the files through the Cloudflare tunnel.

I added Zero Trust Application for two factor authentication for domain Action “allow”, Include selector “Email” and added my email.

Everything works perfectly!

What do I want now?

I want when I share a file link that my friend can download the file and bypass Cloudflare Zero Trust authenticaton.

I added a new Cloudflare Application:*

according to the instructions:

After that, added Action “Bypass”, Include selector “Everyone”

When I open a shared link, Cloudflare doesn’t ask me for authentication. Exactly what I wanted!

Where is the problem?

The page opens, loads and loads and loads, 3 dots appear in the middle of the page and blink and blink and nothing opens.

I tried opening a shared link with Cloudflare Zero Trust authenticaton turned on and it works perfectly.

I tried to completely remove zero trust and everything works perfectly.

The problem is only when I set* to new Application. It won’t open!

I don’t know exactly what the problem is. I can’t figure out the solution.