Cloudflare WP plugin server push does'nt work with WP caching plugins

#1

I tried the HTTP2 server push option from the Cloudflare WordPress plugin and it worked just fine when file optimization options were disabled, but as soon as another plugin minifies the resources and saves a cached version in a separate directory, it won’t be loaded with server push.

#2

Clear cache and try again

1 Like
#3

Still doesn’t work:(

#4

Which cache did you clean? From your CF panel? Browser cache?

#5

I tried clearing the cache from my server, my CF panel and also from my browser. Some resources do load via push but not the ones from the cache folder.

#6

Seems there is conflict between your plugins. The addresses at the client side should be updated upon minifying which is not occurring currently.

#7

The addresses at the client side are correct, they just lack the “Link preload” header. They are loaded by the DOM, without the server push feature.

#8

I use Cloudflare HTTP/2 server push in two websites, both using WP caching plugins (WP Super Cache and SG Optimizer), and in both cases it works fine. The only issue I had was with Safari on iOS, for which I had to reduce the number of files to be pushed for it to work.

If you provide your domain and more details, such as what plugin you are using, users in this community with similar experience may be able to help you.

1 Like
closed #10

This topic was automatically closed after 30 days. New replies are no longer allowed.