Cloudflare Workers suspected of being blocked in China

Some regions reported inability to access worker sites.


image

128.242.245.125 isn’t a Cloudflare IP address - what DNS servers is your device using?

It’s the DNS of our regional telco. Some say DNS is polluted

Yes, if I use secure DNS I can still access

This has been happening in parts of Sichuan and Chongqing for about 7 months! I’ve told Cloudflare about this in a support ticket but they haven’t solved the issue yet and I don’t think they know how to solve the issue based on what little communication they’ve replied on the ticket with. They keep erroneously blaming unrelated things and asking random diagnostics information, and waiting weeks for responses from irrelevant telco departments.

You can solve the problem for your own Worker with some tricks on your own domain DNS (not worker domain), but ultimately this issue does need to be solved by Cloudflare to solve the issue for all properties and services on Cloudflare.

I’m having this similar issue from yesterday.
For me, I can still access worker.dev with port 80 (HTTP). However, if I access with port 443 (HTTPS), I will receive 3 RST ACK packages after sending TLS Client Hello

@MoreHelp This still isn’t solved. Has anyone told the Cloudflare engineers? Wrong IP’s being reported for Cloudflare domains.