Cloudflare & Wordpress: Suddenly Causing Extremely Slow Admin Page Load Times

I’ve followed the page rule recommendations to create a page rule for, but the page rule does not help my issue. A few weeks ago my wordpress site’s admin pages take forever to load (browser will say “waiting for” for 10-20 seconds every time I go to a new admin page). If I enable development mode in cloudflare, this issue goes away, but somehow the page rule that I’ve created with all caching, security, and speed options disable, the issue still happens. I saw a previous forum post on this issue but it seems no one figured it out. There must be a glitch in cloudflare’s caching system or firewall that’s causing this issue, and I can’t figure out how to effectively exclude wordpress admin pages. Has anyone figured this out?

Well, I can only say that I use Cloudflare with Cache Everything and Origin Cache Control option enabled via Page Rules on 60-70 websites working on WordPress.

No issue at all for admin dashboard (which by default sends no-cache HTTP headers and similar, which are respected with Origin Cache Control option), neither any other issue with front-end.

I assume it could be due to the origin host/server, or Cloudflare IPs not being allowed, or about SSL settings (SSL certificate not installed or valid, or WP-admin not working over SSL, while website working on HTTP, wrong SSL option selected under SSL/TLS tab at Cloudflare dashboard, cookies not enabled, using www instead of non-www or vice-versa while not keeping only “the one”, etc).

May I ask which one?

Any errors in Developer Console of the Web browser?

Can you explain how I insure that my site send no-cache HTTP headers? That’s the one think I haven’t checked.

Also I am getting developer console errors whcih are 522 errors; on essentially ever admin page it fails to load various js files. For instance, these errors are from my woocommerce orders page.

Failed to load resource: the server responded with a status of 522 () wp-mediaelement.min.js:1

Failed to load resource: the server responded with a status of 522 () index.js:1

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.