Cloudflare WordPress Plugin Update Critical Error

I have just updated Cloudflare WordPress Plugin from version 3.7.0 installed. Update to 3.8.1 and my site went offline, Wordpress reporting Critical Error. Disabling Cloudflare WordPress Plugin brought the site back online.

It just happend to me too. I did a rollback (with a plugin called WP-Rollback) to versie 3.8.0.
Cloudflair is back on my site. I disabled the auto-update for cloudflair.

The error-mail I got (in dutch):
Foutdetails

===========

Een fout van het type E_COMPILE_ERROR werd veroorzaakt op regelnummer 69 van het bestand /home/ietsnl/domains/iets.nl/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php. Foutmelding: require(): Failed opening required ‘/home/ietsnl/domains/iets.nl/public_html/wp-content/plugins/cloudflare/vendor/composer/…/myclabs/deep-copy/src/DeepCopy/deep_copy.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’)

I tried the 3.8.1 update on another site with a different theme and also got a critical error.

Wordpress reported:

This plugin failed to load properly and is paused during recovery mode.

An error of type E_COMPILE_ERROR was caused in line 69 of the file /home/site name/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php . Error message: require(): Failed opening required '/home/sitename/public_html/wp-content/plugins/cloudflare/vendor/composer/../myclabs/deep-copy/src/DeepCopy/deep_copy.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear')

Disabling plugin brings site back online

we are aware and working on a fix

2 Likes

Yeah for now I just moved wp-content/plugin/cloudflare 3.8.1 and reinstalled 3.8.0 via wp-cli

wp plugin install cloudflare --version=3.8.0 --force

FYI 3.8.2 fix is coming soon https://github.com/cloudflare/Cloudflare-WordPress/releases/tag/v3.8.2

1 Like

The fixed version: 3.8.2 is now available: https://wordpress.org/plugins/cloudflare/

2 Likes

As @adspedia mentioned: 3.8.2 is out and is fixed

1 Like

It Works :slight_smile:
Thanks

Thanks for the quick fix!

Just in case you cannot go back into your wp-admin area, in order to recover access, please perform any of the following:

  1. Manual delete
  • If you can access your wp-admin area, disable the Cloudflare plugin and/or upgrade it to v3.8.2
  • If not, ssh into your server and delete plugin directory located at wp-content -> plugins -> cloudflare. After which you can reinstall your plugin and your settings will be preserved.
  1. Restore a website backup from your hosting provider dashboard

  2. Delete the plugin from the hosting provider “file manager” from inside your cPanel, Plesk etc
    Path to navigate to the plugin inside your FTP folders is: wp-content -> plugins -> cloudflare

1 Like

the same here, I just updated and I have the same problem, I try to uninstall and reinstall and it appears:

Warning: require (/ home / xyz / xyz … com / wp-content / plugins / cloudflare / vendor / composer /…/ myclabs / deep-copy / src / DeepCopy / deep_copy.php): failed to open stream : No such file or directory in /home/xyz/xyz…com/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php on line 69

Fatal error: require (): Failed opening required '/home/xyz/xyz…com/wp-content/plugins/cloudflare/vendor/composer/…/myclabs/deep-copy/src/DeepCopy/deep_copy. php ‘(include_path =’.: / opt / alt / php74 / usr / share / pear ') in /home/xyz/xyz…com/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php on line 69

Hi @JuanDavid what version are you re-installing? Please use version 3.8.2

It looks like we’ve got quite a few Cloudflare eyes here:

Visitor IP address appears to be stuck:

I just installed 3.8.2 - am getting “we think you’re a bot” then requires captcha when attempting to log into WP admin - the problem is admin is skipped and the site redirects to home

Also getting “we think you’re a bot” when running analysis on GT Metrix - astounding speed up but useless without WP admin

That just fixed itself

New problem - when I click the plugins link in WP admin I’m redirected to Home now with a captcha - I can access “add new” “products” and other links but not “installed plugins”

Cloudflare is indicating my site is not a WordPress site - it is - and the Wordpress plugin is not installed - it is.

Some is working my home page speed on moble shrank from 15.4 secs to 1.7 secs (GTMetrix)

Cleared all the caches - seems to have worked

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.