Cloudflare & Wordpress Jetpack


#1

Hi everyone,

I tried to contact the support but they seem not to understand the problem.

I’m using Cloudflare for my Wordpress website.

But the Wordpress jetpack plugin doesn’t work when Cloudflare is active.

I tried to fix the problem with the Wordpress support but they couldn’t help any further.

We tried to disable the WAF, add specific page rules, and many more. Until we tried to disable (pause) Cloudflare.

Out of a sudden everything then worked as it should. But when reenabling Cloudflare the connection between Wordpress and my website is broken again.

Is there anyone who had a similar problem and got it fixed?

If you need more information, just leave a reply, I really need to get this Wordpress plugin and cloudflare work together.

Thanks,
Patrick


#2

My wild guess is it’s Rocket Loader related. Have you tried disabling that in the Speed section?


#3

Thanks @sdayman

I tried it with Rocket Loader enabled & disabled. :frowning:

By the way, the answer from the Wordpress/Jetpack API testing tool is:
“The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (403) [-32300]”


#4

A 403 is “Forbidden”. Is there an entry in the Firewall Events Log in the Firewall page? That tool probably isn’t going to show you what the 403 looked like, but it’s probably coming Cloudflare blocking that activity:


#5

@sdayman

The firewall doesn’t show anything :frowning:

It did show something, but this was fixed after adding all Wordpress IPs to the whitelist. :wink:

And yes, I’m seeing the 403 in the serverlogs too, but only if Cloudflare is active.


#6

Oh…so your server is blocking. Good to know. Is there a way to get the server to whitelist the offending IP? Or figure out why it blocked?


#7

Okay, never mind I just got an answer from my hosting provider:

I had to add the following code to the .htaccess file:
image


#8

This topic was automatically closed after 31 days. New replies are no longer allowed.