Cloudflare Wordpress APO BYPASS

Ive got an odd behavior where the header cf-edge-cachecomes from the origin but it will always sendBYPASSasCF-Cache-Statusandorigin,missoncf-apo-via`.

Please notice I am using uptrends tool as the troubleshooting session advises. No matter how many times I try, home and internal blog posts will always return like that.

Attached, you can see details.

I appreciate any insights towards fixing this behavior!

Without an actual URL to test, I’m afraid we can not assist.

You mean when viewing preview of blog posts while logged in as a Wordpress admin user ? Then that’s expected as APO will bypass cache on Wordpress cookie detection as APO will only serve cached responses to non-logged in user/guests who won’t have the presence of Wordpress cookie. Try clearing your site’s cookies and visit the posts as a guest to see if they cache properly.

Also noticed you’re missing cache-control response headers https://developers.cloudflare.com/automatic-platform-optimization/troubleshooting/faq#why-are-my-browser-cache-control-headers-missing-with-apo and have cf-apo-via origin,miss response headers

Why are my browser cache control headers missing with APO?

The browser cache control headers may be missing with APO if you set your browser to cache TTL to “respect existing headers.”

Do you have browser to cache TTL set to “respect existing headers.” ?

Also see a cookie for AWS load balancer? set-cookie AWSALBCORS= could be interfering ?

Also check AWS LB origin cache-control headers, they could be set to private or no-cache and not public.

1 Like

@sdayman The URL is within the attached image. Let me know if you need any additional information.

Thanks for taking the time to help!

@eva2000 I am not logged into wp-admin, using a anonymous session without any cookies.

As I’ve mentioned, attached is a print from UPTRENDS site which is also not logged in and is the way the APO site instructs to verify APO works on the Getting Started guide as you can see here:

BTW, I have other WPs working fine with APO using same browser and also working on UPTRENDS so that is not a browser specific issue as I was able to reproduce it in several browsers, and I believe you would be able to easily reproduce it there too by visiting the site listed on the first message attachment.

Thanks for your help!

If it’s /wp-json/, that URL returns a JSON response for me, not HTML.

As @eva2000 mentioned, it’s not uncommon for Cloudflare to BYPASS when cookies are involved.

@sdayman Would it be possible that AWS ALB’s sticky session Set-Cookie headers are causing that?

image

If so, would you, by any chance, know a way to ignore that within Cloudflare that would not overlap with APO’s settings?

Thanks a bunch!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.