Cloudflare Will Not Cache Anything, nor will it minify anything

I have just set up my site with cloudflare, my site is being hosted on github pages, and the domain by namecheap.

When I set up cloudflare, I followed the instructions to the letter, and got the “your site is now using cloudflare message”, I added the custom nameservers in namecheap as per the instructions.

However, even though I have the following added:

  • Minify JS, HTML, CSS all ticked under Speed > Optimisation
  • Browser Cache TTL 8 Days under Caching > Config
  • Added a page rule for “mysite.com” with the following settings:
    Browser Cache TTL: 8 days, Cache Level: Cache Everything, Edge Cache TTL: 7 days

None of the above is happenning. I have tried purging cache, hard refreshes, nothing is being cached according to GTMetrix, nor anything under the cache section in dev tools. I have tried multiple variations of the url for the page rule:

https-www.mysite .com/
https-www.mysite .com/*
www.mysite .com/*
mysite .com/*
(Links changed for this forum)

None of them work. I have no idea what I’ve done wrong? Looking in the dashboard, I see a box that says “Great news! Cloudflare is now protecting your site” yet when I then click “Manage Domain” on the right hand side I get a message above my site saying “not on cloudflare” and a red bar at the bottom appears saying “No payment method associated with the specified account (Code: 1208)” which disappears after about 5 seconds.

Have I set something up wrong? I just wanted the free option.

Many thanks.

Since you haven’t posted a hostname, we can’t test hyour site.

1 Like

domain is muggavirtualpilot.com