Cloudflare website is unavailable

I see a couple of issues:

  1. There’s no DNS entry for the apex domain (without the ‘www’).
  2. With www, it’s a proxied (:orange:) CNAME that points to another host proxied by Cloudflare. It would need to be set to :grey: DNS Only.
1 Like

I’m starter so i don’t know how to do it

Here’s a tutorial to fix problem #1:

And to fix #2, you need to edit the ‘www’ DNS record and click the :orange: so it’s :grey:.

3 Likes

@sdayman

Hello,

As @sdayman and @DotMrCode already pointed out the tutorials, and as far as I have checked, you have an MX record pointing to example.com.
Assumming, your A record points as well to example.com.

Kindly, can you please provide us a screenshot of your DNS records from your Cloudflare account dashboard (in case if needed, please mask/hide your IP address column due to privacy worries)?

Moreover, your DNS records at your Cloudflare account for your domain rinikplex.tk should look alike similar as on the screenshot below (just change your.hosting.ip.address to your IPv4 address of your hosting provider/origin where you have your Website and content hosted):

Make sure at first you have:

  • A www pointed to your IPv4 address (of your hosting provider) and :orange:
  • A rinikplex.tk pointed to your IPv4 address (of your hosting provider) and :orange:
  • A mail pointed to your IPv4 address (of your hosting/email provider) and :grey: DNS only
  • MX rinikplex.tk pointed to mail.rinikplex.tk and DNS only

Do you know who is your hosting provider and what IPv4 address have you got, either where can you find it?

Later on, we can provide more help due to the possible missconfiguration on the SSL side and your other issue if so.

1 Like

DNS

@fritex

Your A record is pointing to a local IP address not your hosting IP. Set that record to the IP address your hosting provider has given.

2 Likes

so?

@Walshy

I’ll try to delete the website and add again

If you are using your own computer (home network) for a web server, hopefully if you have setup port forwarding at your router intraface as well as having web server setup correctly and having a public static IP address, otherwise you can find your public IP address using this Website:

Moreover, maybe you have Dynamic DNS and wanting to achieve access to your host at your home network?

I already have another domain name is: rinikplex.cf but

will anyone do it to me already? because I can’t do that

I have a cloudflare website but i have error on the website. My domain: http://rinikplex.cf
Please help

Image

What is the value for the A www record and A rinikplex.cf record?
Are both of this records :orange:?

Moreover, what do you have slected under “SSL tab” - Full SSL or Flexible SSL?

HTTP website is working, but now for https://rinikplex.cf/ it shows up SSL_ERROR_BAD_CERT_DOMAIN.

Certanly, your SSL certificate does not cover www.rinikplex.cf, but only neither rinikplex.cf.
Is your A www record on :orange: or :grey: cloud?

Meaning you do not have an valid SSL certificate generated at your host/origin, or it is invalid.

Moreover, depending on the SSL tab for your domain and selected SSL option (hopefully Full SSL or Flexible SSL), furthermore issues can be shown up, but also can be resolved if they happen.

Please, before proceeding with:

  1. Generate an SSL certificate at your origin/host to cover both www and non-www domain or generate Cloudflare CA Origin certificate for your hostnames and upload/install it at your origin
  2. Enable the “Full SSL” option at your DNS dashboard at Cloudflare account
  3. Make sure you have :orange: for www record and rinikplex.cf record and under “SSL tab” have the “Flexible SSL” option (not recommended - see below!)

About HTTPS and SSL erros, please find more information here:
https://support.cloudflare.com/hc/en-us/articles/200170566-Troubleshooting-SSL-errors