Cloudflare was working perfectly until this morning - Stopped by itself

Hi all

As of this morning, I was not able to my website via Cloudflare (Error refused).

I found if I overrode CF in my hosts file (with actual IP address), then it worked fine. So I removed the proxy on Cloudflare. This was about 6 hours ago, and it hasn’t propagated. Ok - So these things could take time, however:

I have now worked out that all my pings to my domain, resolve to the same proxy address, even made up subdomains…

In other words:

maindomain.com --> incorrect proxy IP 89.31.143.1
legit-subdomain.maindomain.com --> incorrect IP 89.31.143.1
DFGDFGdfgdfgdfgdfgfdgfdgdfe353434.maindomain.com --> incorrect IP 89.31.143.1
blahblahdfgdg44yougetthepoint.maindomain.com --> incorrect IP 89.31.143.1

So something is seriously amiss… My other Cloudflare sites are working fine, and I’ve also tried pinging non-existent subdomains, and those, as expected, do not resolve to anything.

Hope somebody can assist!

Are you using Cloudflare’s nameservers? Do you still own your domain?

The nameservers were updated a months ago - to my knowledge this can’t be undone without my explicit actions.

Nserver: gene.ns.cloudflare.com
Nserver: lex.ns.cloudflare.com
Status: connect
Changed: 2020-11-17T10:58:05+01:00

I can’t see the expiry date on my domain tho (it’s actually my client’s, so I have asked her, but she def owned the domain a month ago when we did the change)

Without knowing the actual domain name, there’s very little we can suggest.

Fair enough:

Ok, I just realized I’ve got this all wrong…

So the IP addresses are all pointing to the original server, and I’d left that stuff in place, and there was a wildcard CName which explains my ability to ping anything.

However - No changes which I make on CF reflect.
One of the new subdomains I added, which has worked for the past month was 123.does-not-matter-any-more.de .

The fact that switching the proxy on and off makes no difference, and this overnight change, does make it feel like it has reverted to the previous NS, but it hasn’t (as far as I can tell)

Apology for the confusion, but yeah, something is still not right!

It doesnt look like that site is using Cloudflare’s nameservers

1 Like

Hmm
Ok, I did not think this was possible… In my experience, action needs to be taken by the current owner of the Nameservers) in order to change them, and once this is done, the reverse would need to take place from the new owners side.

Please help me understand?

Thanks for your help so far

Cloudflare has no control over which name servers you set at your registrar. Your best bet would be to contact them regarding this issue.

Perhaps I am confusing this process with moving a domain…

Cool. Thanks!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.