Cloudflare WARP not connecting (Windows)

Hello, I’m new in the community.I am having issues connecting with WARP since yesterday.Before that it was working fine.I believe that ISP has to do something with that because i am getting this issues after a ISP maintenance.Is there any possible solution for that?


This is just for the DNS service, and not the VPN?

Can you try and then post the link to your results?

Related post :

I did some testing and it looks like Indian ISPs (Jio / Airtel Tested) are blocking Warp.
( DNS is working fine)

I installed Warp In a VM .
Connected Host PC to a VPN. Then tried connecting to Warp in the VM & It worked.
However when I tested with my real IPs provided by my ISPs, Warp failed to connect.

1 Like

same thing happening to me also on pc. my isp is hathway, seems like they’re also blocking warp.

here’s the link to my results*MTM3NjQ2MzE5NC4xNjM4Njg1Njcz#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJObyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjEwMDEiOiJObyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IkJPTSIsImlzV2FycCI6Ik5vIiwiaXNwTmFtZSI6IkhhdGh3YXkiLCJpc3BBc24iOiIxNzQ4OCJ9

All Indian ISPs, started blocking same day? I think, it can be something from cf, maybe.

So… I did some more testing with Wireshark…
Looks like all ISPs are blocking warp ports: 2408,1701,500,4500
for Warp Ingress IP Range: (Port 80/443 works, only warp ports blocked)

This looks very much like government censorship.
or maybe i am thinking toomuch.

  • user13116 said it happened to him after ISP maintenance.
    I have a feeling the bigger ISPs(Jio/Airtel) updated their firewall without downtime. While user13116’s ISP took a maintenance break.
1 Like

I’m also facing this issue. Jio went away for 8 hours for maintenance and then WARP stopped working for me.

Can we get anyone from CloudFlare WARP team to take a look here? To be just sure?

My help link

I did nmap scan, following ports are open.

21/tcp open ftp
80/tcp open http
443/tcp open https
554/tcp open rtsp
1723/tcp open pptp
8080/tcp open http-proxy
8443/tcp open https-alt

That’s just tcp though, none of udp ports respond. I feel, it’s data centres in India and not ISPs blocking, it’ll be bizarre, if they’ve started blocking it on same day? There is no court order or news for coordinated shutdown.

1 Like

So i tried to connect WARP using Vi network.Its working fine…

Check the result

WARP uses the wireguard protocol, so its an UDP connection.

Indian ISPs have a track record of blocking stuff even if its not banned.

You’re right, need update from CF team.

I’m facing the same issue on a GTPL connection. At first I thought it might be something to with the update so I tried a few past versions of the WARP client and every time it says that it failed to register the client.

It is suspicious that all ISPs started blocking WARP all of a sudden.

1 Like

Very suspicious, or are they using some russian backend, jk? Russia recently blocked Warp.

Hi sdayman. sorry just chat in. my bad. yeah actually i was burn out with the heavy thing to cover up. and im here as the beginner that try to understand about this new commnunication technolgy. hope you understand my situation. and about WARP not connecting on windows itself, i was confused about that. And i just install the DNS Changer and WARP on my iphone7 and just use this laptop via thether. I was connect DNS changer with using, but on WARP, im not connect it. Is it different about the both of the app. I mean about the for noob question.thanks sir

Hi mr sdayman. Im just set that on windows with the instruction. thanks about that.

Hey guys,
At first, I also thought it must an ISP block but having read what you say here, especially the Indian case, I start to think that it’s not on the ISP side but it’s really on the Cloudflare.
Here is the topic I started a cpl days ago and there is an update in the latest message. I am copying it for your convenience, so we can continue the investigation in this thread.

Today I connected my mobile to the Internet via the other Wifi and other ISP, so WARP was suprisingly OK.
After that I connected to the Internet via 4G and WARP was OK again.

ISP in Belarus hierarchy is as follows:
Beltelecom - the 1st lvl, monopolist. - no block, WARP works fine for its clients.
CosmosTV - the 2nd one, lower. - the fail is here (I am their client).

Cell operators: MTS, A1 - WARP fails. I dunno which of the 2 ISPs are used by the cell operators but it seems to be CosmosTV from what we see.

After I got back to the CosmosTV network, my phone started to fail again with WARP and no way to make it work again. (I have no access to Beltelecom more to try a successful connection).

Russia has officially banned it, and I thought VPNs are illegal in Belasrus?

it is not working on GTPL Broadband, maybe there is an issue with isp or Cloudflare itself. All the servers are operational though !!