Cloudflare Warp not connecting and memory leak

Cloudflare Warp isn’t working with Windows 11 (Build 22000.194), connection fails with ‘An error occured while connecting to Warp’. Uninstalling fails if the Cloudflare folder from C:/ProgramFiles/ isn’t removed manually and warp-svc.exe is causing a memory leak, if it keeps running in the background it reaches 5 GB+ usage. Only fix is to stop it, remove the folders and uninstall warp.

Tried installing warp from the latest installer and also v1.5.461.0 using chocolatey but the issue persists.
How should I fix this issue ?

2 Likes

Same Problem
I have this problem in latest version (1.6.28) on 2 of my windows 10 21h1 systems

Yes this is a huge problem for me.
Memory leaking and usage of WMI Provider Host taking all the CPU threads.
Even a youtube video is interupted.
After turning off warp, everything back to normal.
version 1.6.28.0 windows 10.

Same issue here on Windows 10 21H1 19043.1288.

The entire system becomes unresponsive. Task Manager shows System Interrupts at 100% CPU usage, and warp_svc at 50% total system memory. (On my 16GB htpc, it consumes 8GB. On my 64GB workstation, it gets to 32GB.) Only way to recover the system is to kill warp_svc. As long as Warp is installed, even with it disabled in the Windows startup settings, the problem persists.

1 Like

is there any news for fixing this problem

1 Like

Same here!

Since the last update (v1.6.28), Warp does not connect. when pressing the button it says:
“an error occurred connecting to WARP” pops up as a notification on Windows 11.
And the software shows: The Cloudflare WARP is not available. Try rebooting."
I have exited the app and restarted it and it did not fix it. Rebooting Windows didn’t either.
I have tried to uninstall it, but it does not uninstall either!
Also, I see in task manager it shows “warp-svc.exe” is using 3.1 GB of memory and 16.4 percent of my CPU power which is an intel core i7-8750 @2.20 GHz



Yes it has issues with uninstallation as well, what worked for me was deleting the folder after stopping the service. If it isn’t stopping you can take a look at Kill a Windows Service That Stucks on Stopping or Starting | Windows OS Hub .

You can also boot in safe mode then delete the Warp folder and then boot the pc normally.

As for a fix for the memory leak and it not working I have no fix as of yet.

Problem probably solved by enabling and installing beta-version.
So, warp-svc.exe updated from 0.2 version to 0.2.1 and main Cloudflare WARP app from 1.6.28 to 1.6.172.1.