Cloudflare warp local proxy mode no working

environment:
windows11, chrome, China mainland, ipv4 dns: 1.1.1.1 1.0.0.1 ipv6 dns: 2606:4700:4700::1111 2606:4700:4700::1001

detail:
when i config Cloudflare warp to use 1.1.1.1+warp, it works fine , the network speed is ok.
but when i config Cloudflare warp to use local proxy mode, i config chrome to use localhost:port for proxy using socks5, it does not work. when i set to socks4, it works sometimes, but the network speed become very slow. and most times, it does not work.

2 Likes

Same problem. If you select the warp-cli set-mode proxy setting in Ubuntu 22.04, then chrome does not work through this proxy, and the same Smplayer player does too. If you install any Extension in chrome with the choice of socks4 (for example, Proxy SwitchyOmega), then it works through socks4.
There seems to be a problem with DNS in WARP PROXY.
Because if you disable “Send DNS requests through a proxy when using SOCKS 5” in the network settings in Firefox, sites are downloaded, and if you enable it, they are not.

In applications where DNS is not needed (Telegram, for example) - WARP PROXY SOCKS 5 works normally.

What is wrong with DNS in WARP PROXY SOCKS 5 and how to fix it?

He wrote through a car translator.

Same problem here.