Cloudflare WARP linux use IP local to connect websites cloud oragen

I was wanting to go back to using WARP on my linux computer
But I always run into some problems.
At the beginning, when I started using the warp, it didn’t work directly, I had to do some crazy configuration to get it to work (until then I didn’t have access to the internet) and if I moved more, I lost again
Then I left some time without using the warp
I tried to use it back now and I find that WARP is broadcasting IP 172.16.x.x (x is a number) to orange cloud websites instead of my real IP
Taking a look at warp-cli settings is a local IP
And some websites are blocking my access even by the cloudflare itself as it is not my real IP it blocks
I would like to know why this problem and how to solve it

using curl in the terminal
says my real IP and the warp is on (normal)
but when I enter through my browsers (I tested more than one and formatted one of them even thinking it was some abnormal problem) the local IP and warp=off appears

Are you using Ubuntu, Debian, CentOS, Fedora, or RHEL (the officially supported distros)?

I’ve tried using it on Arch before, and it took hours to fix the settings up so it was just right for me, and I had some similar weird problems before. As soon as I tried the Live ISO for Ubuntu, it worked straight out of the box. WARP has been the single reason why I’ve switched back over to Ubuntu.

i am using linux mint at the moment
But I’ve had problems already mentioned in other distros that have always been based on Ubuntu

A sábado, 18 de dez de 2021, 04:26, neuronbutter via Cloudflare Community <[email protected]> escreveu:

Out of interest, is there a difference when visiting and I’ve had IP addresses forwarding properly, and the DNS just breaking if I didn’t use the SOCKS proxy.

Via curl has no difference
But in the browser after a little time (it becomes normal for a while) the cloudflare one is:

uag=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36

result: on some websites

on it’s normal with my IPv4:

ip=85.x.x.x //my ip
uag=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36

Note: When I’m only in mode: DnsOverHttps
on cloudflare my IPv6 appears and on my IPv4

doing some more tests
using proxy mode warp works
but it doesn’t affect all the connection
tcp connections use my normal IP
when used in the past it affected everything

May I ask if this error you got when visiting your own website or someone else’s?

If that’s on your own websites, kindly may I ask you to check your Firewall Events tab if any appear? You can find the specific one by looking for the value of the Ray ID .

Otherwise, if you get this error while visiting someone else’s website, I am afraid you cannot do anything. You can try to access it using a VPN or over a TOR, but I do not guarantee because it could also be blocked and restricted too.
It could be that the owner of the domain name you are visiting is using security options available to him to protect his website either by blocking IPs, ASNs, countries, etc.

The site can block for any number of reason, that’s up to them and not something this Community nor cloudflare can do anything about.

Helpful articles which contain useful information articles about 1020 Access Denied error page can be found below:

someone else’s

That’s not the problem
the IP that appeared in the access denied
is a local network IP (searching the IP in ipinfo is not anyone’s)
the problem here is that WARP should provide the true IP to sites protected by cloudflare but is providing a local IP (which by default shouldn’t happen)

from what I’m testing using in proxy mode resolves and:

to complete just using the steps in the WARP documentation
gives this problem
which by the way does not talk about the proxy mode which is what works (for warp)
and everything I said is referring to non-proxy warp modes (which interferes with the network devices

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.