Cloudflare warp daemon on Ubuntu

I’ve been having trouble getting my cloudflare warp daemon (warp-svc.service) running on my Ubuntu 20.04 machine. I installed cloudflare-warp package using apt and then ran sudo systemclt start warp-svc.sevice and got the following error in the syslogs:

Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z DEBUG urt::rt: MicroRT::spawn: <unknown> on WARP main thread
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z DEBUG urt::rt: MicroRT::spawn: <unknown> on WARP main thread
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z DEBUG warp::warp_service: Version: 2021.10.0
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z DEBUG warp::settings: Loading settings from file "/var/lib/cloudflare-warp/settings.json"
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z DEBUG warp::warp_service: Settings: Always On: false; Switch Locked: false; Mode: Warp; Cloudflare for Families: Off; Disabled for WiFi: false; Disabled for Ethernet: false; Enable DNS logging: true; Fallback d>
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z  INFO urt::rt: Stopping urt name="WARP main thread"
Dec 02 22:39:28 r11 warp-svc[301850]: 2021-12-03T06:39:28.853Z  INFO urt::rt::unix: Dropping urt runtime name="WARP main thread"
Dec 02 22:39:28 r11 warp-svc[301850]: Error: NetworkInfoError
Dec 02 22:39:28 r11 systemd[1]: warp-svc.service: Main process exited, code=exited, status=1/FAILURE
Dec 02 22:39:28 r11 systemd[1]: warp-svc.service: Failed with result 'exit-code'.
Dec 02 22:39:29 r11 systemd[1]: warp-svc.service: Scheduled restart job, restart counter is at 5.
Dec 02 22:39:29 r11 systemd[1]: Stopped Cloudflare Warp Client.
Dec 02 22:39:29 r11 systemd[1]: warp-svc.service: Start request repeated too quickly.
Dec 02 22:39:29 r11 systemd[1]: warp-svc.service: Failed with result 'exit-code'.
Dec 02 22:39:29 r11 systemd[1]: Failed to start Cloudflare Warp Client.

My question is, what does the NetworkInfoError mean here? Is there more logging I can get to debug this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.