Cloudflare WARP client - pausing specific networks not working

I’m not overly IT literate, just a Dad trying to get by setting up content filtering for my 9yr old son now that he has a laptop for school.

I’m big on privacy and we’re teaching our kids from a young age the value of digital privacy. Mainly as a matter of principle. Things such as using Bitwarden, using FOSS where possible etc. We’ve even setup linux mint on the other side of his machine for him to use with anything not school related.

My query relates to Windows 10. It’s his school laptop. I originally had OpenDNS Family setup at the adaptor level and that was great for centent filtering. Nice, simple, elegant and worked well. However, his school network doesn’t allow use of a DNS server so when he’s gone to school they’ve had to put his DNS settings back to auto. That’s absolutely fine on the school network, where they have excellent content filtering, but it means his computer is completely unprotected from adult content and malware on every other network.

I could setup OpenDNS (or Cloudflare etc) on our home network but that still doesn’t keep the laptop protected on other networks beyond School and home. For example, if he is at a friend’s place, tethering off a phone etc. Having the content filter at device level is much preferred.

I met with the school IT representantive and they were very patient and helpful. He recommended trying Cloudflare as it has a windows client that will allow the DNS to temporarily disable on the school network (only) via an exclusion. Brilliant! That was exactly what I was after.

I’ve since installed the Cloudflare windows client and it is very easy to setup and get going. I can see in the system try it’s working and, when set to for Families with Block Malware and Adult Content I can see sites such as malware.testcategory and nudity.testcategory are blocking as required. Once that was working I’ve then sought to setup a network to exclude. Believe it or not, we don’t have WiFi in our house. So I’ve setup hotspot on an iPad to connect to. The ipad hotspot is named “Steven’s iPad” and when I connect with the windows laptop I can see and confirm that this appears to be the SSID. However, when I specifically add “Steven’s iPad” as a connection to be paused in the windows client (preferences / connection / connections will be paused when…) the Warp connection remains active. I further check by trying malware.testcategory and it shows it as still blocked i.e. it hasn’t been blocked.

This shows me that something with how I trying to exclude this wifi network is not working. It’s worth noting that the check boxes “Disable for all Wi-Fi networks” and “Disable for all wired networks” both work as expected, it’s the paused connections specifically listed under Preferences / Connection / Network Name that do not (for me).

Please help. I’d like to get this sorted so his laptop can be suitable protected for content on networks outside of school. I wouldn’t be too fussed as a teenager, but online content can be pretty confronting and hardcore for a 9yr old.

I can’t try it with the school network easily. I’ve noted the network details from a prior visit, so I’m hoping to get it working in principle for a wifi hotspot, or other wifi network such as a neighbours, then add the school network once I know it works in principle. I can then do a single trip to school with my son to verify it’s all good then Bob’s your uncle.

Update, this is now working. No idea what the issue is, but it seems specific only to hotspotting on my ipad. On other wifi networks and hotspotting off an android phone it’s fine.

Now just trying to stop the client being able to be switched on and off by my son. That seems to be able to be implimented with Zero Trust login but having a few issues with that, specifically with “Invalid Team Name” when I try to connect from the device at the warp client… I’ll have a search and see if I can find the answers.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.