Cloudflare Warp Beta (now Argo Tunnel)

When running on Windows 10, Warp version: 2017.10.0 (built 2017-10-03-1057 UTC), configuration gets created successfully, however when trying to start the Hello World sample by executing Cloudflare-warp.exe --hostname warp.domain.com --hello-world, following error happens:

Unable to load Yaml file 'C:\Users\<username>\.Cloudflare-warp.yml': inner error:
'unable to determine how to load from path C:\Users\<username>\.Cloudflare-warp.yml'

A temporary fix which worked for me is to place the configuration file in the same directory as the executable and run it with param –config .Cloudflare-warp.yml.
I tried running the command line with elevated priviliges but it didn’t help either.

Having some trouble running an https only service behind Warp.

Let’s Encrypt seems to fail. :frowning:

Cloudflare-warp version 2017.10.0 (built 2017-10-03-1057 UTC)

Everything else is pure awesomeness! Really like the fact that I can now run multiple services on one local machine without having to worry about ip/routing/…

Mac os 10.13

yep thought as much :slight_smile:

Whats the long term goals for it thought ? to run as a production system to completely hide web servers etc behind you guys?

I’d very much like more control on how warp origins are connected. It’d be nice to for instance add them as part of load balancer pools. Perhaps expand the api so one can ‘glue’ the missing pieces after the origin is connected.

1 Like

Thanks @pkernstock!

Thanks @romainmenke! Just to clarify - you were already using let’s encrypt on that server, and once you added Warp, you got an SSL error when trying to connect to the application?

@alex6 - we like the added security of never having to expose an origin. We also think it can later on be used for automatic service discovery/routing - you spin up Warp, the service is now registered, and you can control how traffic is sent to it.

Sorry for the late reply.

I tried Warp in combination with an Upspin server which uses Let’s Encrypt. It is possible that this is something that needs to be handled in Upspin and not in Warp.

During initial setup of Warp, following the login step… I just wanted to confirm that when selecting a domain, the next step is to create a subdomain? I was a bit concerned about loosing my current zone configs. Thanks

I’m getting the below error when starting. Am I missing a step here?

Cloudflare-warp --debug --hostname THEHOSTNAME http://localhost:80
INFO[0000] Proxying tunnel requests to http://localhost:80
INFO[0000] Starting metrics server addr=127.0.0.1:34117
INFO[0000] Connected to ORD
ERRO[0000] Cannot register error=“Server error: Cannot decode empty certificate”
INFO[0000] Metrics server stopped
INFO[0000] Quitting…

@chris.rosa excited you are setting up Warp. When you set up Warp, you can select which subdomain it work on.

i.e. Cloudflare-warp --hostname subdomain.domain.tld

My suggestion is to try out Warp first on a test domain so you can see it in action.

1 Like

Thanks @romainmenke! We’ll take a look.

1 Like

Is it possible to use websocket connections over warp to. In my test i was unable to connect successfully.

1 Like

Thanks for reporting @user34! We’d love to debug.

  1. Any chance you can open up your certificate in the text editor and see if you have the private key block, certificate block and warp token block? The cert should be at /Users/YourOSUserName/.Cloudflare-warp/cert.pem

It should look like:
-----BEGIN PRIVATE KEY-----
lots of text
—END PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
lots of text
-----END CERTIFICATE-----
-----BEGIN WARP TOKEN-----
lots of text
-----END WARP TOKEN-----

  1. Can you also try specifying the cert when you invoke warp?

Cloudflare-warp --hostname host.example.com http://localhost:8080 --origincert /Users/YourOSUserName/.Cloudflare-warp/cert.pem

  1. Can you also check if there is anything in ~/.Cloudflare-warp/cert.pem ?

  2. And lastly, can you tell us what version of the Warp client you are running? Cloudflare-warp --version

Thanks!

1 Like

There’s no certificate generated when running Cloudflare-warp. Just the initial login yml was created. Should I reinstall it or anything?

Also, it’s a Linux server.

I have it working now. I upgraded the version below to the latest Debian file. Not sure why it didn’t auto upgrade. The newer version had the certificate setup process while the old one didn’t.

Cloudflare-warp version 2017.10.0 (built 2017-10-03-1057 UTC)

@user34 brilliant, thanks!

This is related to setting up warp, as others have mentioned, login doesn’t work, but in my case, the command is broken.

image

This is on Ubuntu 16.04, installed today. Installed via Cloudflare download links and dpkg.

In addition, commands such as Cloudflare-warp --api-email-value value are not actually updating the config file. Manually creating ~/.Cloudflare-warp.yml results the error Cannot find a valid certificate for your origin at the path:

The error says to run Cloudflare login, which is not runable.

Once I installed xdg-open, it gave the link to open the url.

As xdg-open is required, it should be added as a dependency to the package.

It is not installed by default in the server editions of ubuntu, I am not sure if thats the case with debian or other oses.