CloudFlare warning / Facebook / AddThis

Hello, I hope someone might point me in the right direction to solve an issue when trying to share a web page (on a Joomla site) to Facebook, which uses “AddThis” function. We have tried this with 3 different users, with 2 different results, neither of which are what we intend! We have tested this on more than one page of our website with the same results.

I am using one of our website’s ‘blog’ pages as the example: https://www.catchat.org/index.php/blog/1819-cats-dogs-live-together

When people try to ‘Share’ the above page using the ‘share’ option at the bottom (which uses’ AddThis’), they are either getting a notice saying “Attention required! | Cloudflare” or otherwise they are able to share the page OK but no image appears on Facebook, just the page Title & description, (see both scenarios in the screenshot attached)

Ideally we would like both the text and an image from the page to show on Facebook posts when someone shares the page. After some research I ended up at Facebook’s debug page developers.facebook.com/tools/debug so I put the above URL in there. The “Link Preview” shown for this page is perfect - just what we would like Facebook to post when someone shares the page (Image plus page title & description) but that isn’t what happens! Also on that debug page it shows 2 warnings, so I wonder if either of these is why there is an issue, as follows:

Inferred Property: The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.

Missing Properties: The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id

I’m afraid I don’t know what either of these two warnings mean, as I have never come across “og:” in all the time I have worked with websites, that is a new thing to me, so any advice welcome.

As I say, when different people have tested this for us, we get two different results when trying to share the same page, so I am currently confused. I don’t know whether this is a problem with our web pages, or something to do with CloudFlare or Facebook?

Thanks for any help!

Just an Update to my original post; I have resolved one issue - the “Attention required! | Cloudflare” notice that appeared when someone wanted to share one of our web pages to Facebook. That part is now resolved by whitelisting Facebook’s ASN’s in CloudFlare’s IP page rules.

However I still have the problem of facebook not showing an image when sharing our web pages to FB. Even though when I look at a sample page in Facebook’s debug tool, it shows an image on the post preview - but in reality, when sharing a page to FB no image appears. So I’d still appreciate any advice on that, as that is still a problem - although maybe not to do with Cloudflare!

Thanks!!

Hi,

Check here if the Hotlink Protection is ON:
https://dash.cloudflare.com/content-protection

By your description it sounds related to this feature.
If its ON try setting it OFF and confirm if your problem is fixed.

Br,
Rui

1 Like

Hi Rui,
Thanks for the suggestion. I just looked and our “Hotlink Protection” is already switched to “Off”.
Any other clues welcome!

Update to say that I have now resolved this issue, so am posting here to say how, in case anyone else has this issue.
The problem turned out to be that the ‘AddThis’ function wasn’t playing ball with Facebook due to the “og” tags not being present. So I installed an OG extension (Ogplus) and all is now fine!
PHEW!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.