Cloudflare & Vultr HTTPS not workign

I’m using vultr as my provider, and cloudflare as my registrar/dns provider. Vultr has a setting in the firewall that specifically allows cloudflare ips in. I’ve set a rule to allow 443 (and 80, just to test) from cloudflare IPS, and block https from all others.

In cloudflare, I have both my A record and my CNAME (www) set as proxied through cloudflare. When I only allow HTTPS from cloudflare, I get a 524 error from cloudflare. IF I add a rule in vultr to allow HTTPS from, then everything works. I have also tried changing SSL mode from Strict to Full and back, but this makes no difference.

I’ve asked vultr about this, and their response was basically “setting source to cloudflare allows cloudflare IP’s in only”. This wasn’t super helpful, but I’m wondering if it’s something on the cloudflare side.

FWIW, I’m using letsencrypt on my vultr server, so full/strict should both work.

Am I missing something here? Basically I want to block all access to my site unless it goes through cloudflare.


524s are covered at Community Tip - Fixing Error 524: A timeout occurred. That error is not exactly SSL related, so for starters you should leave everything at “Full strict”.

Then, if you get that error it would indicate the connection itself worked but your server did not respond within 100 seconds. If you are saying it works when you remove the network restrictions, that would suggest it actually has something to do with their firewall, maybe the initial TCP connection works but subsequent outgoing data packets are blocked. Check out the firewall settings for any of that and make sure everything in regard to these IP ranges is allowed.

If something is not clear you might want to contact your host’s support again and clarify if there is anything else you should do, you can point out that Cloudflare can connect but your server does not send anything back.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.