Cloudflare Universal Certificate has expired

In the Cloudflare Dashboard/SSL/Edge Certificates it states that the Universal Certificate has expired. Because of this my domain is not secure. Cloudflare has failed to renew the certification since 10/11/22 - now 16 days ago. Because this is managed by Cloudflare there is nothing I can do. I hope Cloudflare is reading this and will respond.

1 Like

Have you tried disabling universal SSL, waiting 5 minutes then re-enabling it?

Disabling Universal SSL removes any currently active Universal SSL certificates for your zone from the edge and prevents any future Universal SSL certificates from being ordered.

Don’t believe it can be reenabled based on the above.

That message translates to not allowing one to generate any universal ssl certs while the feature is off.

You are good to disable and re-enable.

1 Like

Went ahead and disabled, waited 20 minutes and reenabled. Sadly it just brought back the original, expired certificate. Doesn’t look like this will help.

1 Like

Please make a support ticket here. The ticket will probably auto close, but post the ticket number here, and we can escalate.

1 Like

Tried, but Customers on our Free plans can only submit tickets for billing, account, and registrar issues.

1 Like

Make it for an account issue

No luck. Simply will not let me create a ticket. Tried account, billing, registrar

1 Like

Can you share your domain here and I see if I can get someone to make a ticket for you.

1 Like

Thank you. ourfamilylives dot com

I have escalated this.

Much appreciated.

Could you share the ticket number? So far the certificate is still expired.

There is no support ticket number for you at the moment but rest assured it has been escalated further now as well.

If you want to try a fix yourself, you could try switching the CA manually. Try google rather than digicert though.

Universal Certificate still expired - shows error on Edge Certificate Dashboard. In an effort to try and get a new Certificate, I removed the website from Cloudflare, then added it back. No joy - just brought back the expired Certificate.

I find it hard to believe I am the only client with this problem. Escalation is not happening. Soon will be a month expired. Shouldn’t this be flashing on some Cloudflare dashboard somewhere? I am wondering if this has something to do with the recently added backup certificates?

Hi @don18,
As I mentioned in my reply, this should now be resolved.

Indeed it is. Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.