Cloudflare Tunnels Unsupported Protocol

After setting up a Cloudflare tunnel, I reach the error message uses an unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH.”

I have followed the decision tree in the docs here and confirmed 1) my ssl cert is active, 2) the DNS records in question are proxied, 3) I am not using a custom certificate, and 4) I am not using a multi-level subdomain. Given this, I am not sure what else to do to correct this error. Can anyone help me? Happy to post whatever logs or information would be helpful, just not sure what else would be needed at this point. Thanks.

Can you post the actual website URL that is facing the issue?

I’m not seeing the error in question.

Perhaps you can check if your DNS cache resolves to the correct Cloudflare IP address for this website? The best way you can do is to run ipconfig /flushdns in your Command Prompt (assuming that you are using Windows) to clear the DNS cache. Or, you may also need to check if you are using the latest browser to access your website.

Very strange. I flushed the cache as you suggested, but no change. One interesting wrinkle…if I try on other browsers (Firefox, Safari) I get the same error, but if I try just, Chrome triggers the same error but other browsers show the parked domain page from porkbun. I did recently park the domain at porkbun to reset the DNS records prior to moving it to Cloudflare, but not sure why that page would still be showing. Could that be related, or a coincidence?

Everytime when you make changes in DNS records would take sometime (from few hours to over night) to update on the internet. I tried your website, its showing Nextcloud login page and working properly.

I usually do a DNS lookup to check if the changes I’v made has been reflected by using nslookup, dig command.


If it is pointing to Cloudflare IP, then it is updated & working. Blank means not yet updated, and you have to wait for awhile.

1 Like

Interesting. Since you both were able to see the website I tried accessing it via my phone with wifi turned off, and that worked perfectly. So that’s progress! I am continuing to get the ssl errors with any browser on any device connected to my home wifi, though. Sorry if it’s a stupid question, but why would this be?

Have you checked “No TLS verify” option in TLS section of your tunnel → Hostname Page?