Cloudflare Tunnel with Warp Clients


I am attempting to use the new Cloudflare tunnel running via docker to enable access to my private network. I have the warp client installed on an IOS device and have accepted the Cloudflare certificate. However upon visiting an ip in my private network via warp, i get the following

ERR Failed to handle QUIC stream error=“cloudflared received a request from WARP client, but your configuration has disabled ingress from WARP clients. To enable this, set “warp-routing:\n\t enabled: true” in your config.yaml” connIndex=3

I have enabled quic via --protocol quic in my docker command but this hasn’t seemed to change anything about being able to access my network.

Furthermore i am also having issues getting my private DNS names to work within the tunnel as well, accessing via ip i get the 502 page and that warp error but using DNS doesn’t seem to traverse the tunnel at all.

Are you using ?
If so, then the UI generates and handles that in your config automatically. As soon as you create a Private Network CIDR in the UI, it will push that config change to the running cloudflared tunnel process.

If you are running cloudflared tunnel with locally managed config YAML file, then you have to make sure you follow what the warning is saying and add:

  enabled: true

to your config

Did you already follow this troubleshooting?

Edit: well, if you do not have warp-routing enabled as noted on my first comment above, then private DNS resolution won’t work either since it relies on that.
So maybe both problems will be solved once you address the first part of my response.

Yes i am using the new easy tunnels. So i would expect the Ui to generate everything i need since i added my private network both as a network in the tunnel config and as an include option in the network settings, but i continue to get the 502 and warp error in the cloudflared logs

Welp, looks like i just needed to remove the private network from the UI, save, and then re-add the private network. Once i did that the warp-routing is enabled log message popped up> however it seems that DNS resolution is still not working. I saw in another post it took some time for someone else to have their DNS resolution working so i will let this sit unless you have any other suggestions to have DNS resolution work now that warp routing is enabled

If the only problem left is DNS, then have you checked all the troubleshooting and guidance in ?

Dig works when i run dig @ hostname.local and it responds as expected but opening a web browser and trying to go to that same hostname still fails.

Chưa nhận dc

thanh hòa