Cloudflare tunnel with docker issues

Hi everyone, total noob here.

I am running portainer on a raspberry pi 5, and I have the following containers running:

  1. nextcloud with IP [5443:443]
  2. nextcloud_db with IP [-]
  3. portainer with IP [9000:9000, 9443:9443]
  4. cloudflared:latest with IP [-]

They are all connected to one user-made bridged network called crossnet.

I have configured a tunnel by using the cloudflare recommended process for Docker, and the status of the tunnel is “HEALTHY” in the dashboard.

My tunnel is configured as | Type: HTTPS and URL is

No matter what I do, the website doesn’t load and the only way for me to access nextcloud is by going to in my browser…

I apologize in advance for my lack of knowledge - I’ve researched to the best of my ability and tried everything I could to no avail. Please help if you are able. Thank you!

Hi @reggie12

Where is Cloudflared installed? On the container or on the host machine? Have you tried using in the private network tab for your tunnel on the Cloudflare Tunnels dashboard? It is required to add the private IP of the service you want to broadcast over the Internet so Cloudflare knows where to reach out for your resources.