Cloudflare tunnel with Docker causes internet connection drop

Hi guys, I’m new to Cloudflare and Linux.

I tried using Cloudflare tunnel to remote access my Virtualbox running Debian 12.

However, I have the following issue when running it on LXDE.

When I run the docker code as shown in the Cloudflare screen [docker run -d --name cloudflared cloudflare/cloudflared:latest tunnel --no-autoupdate run --token]. I will lose my internet connection when the daemon starts.

After which, I managed to resolve the issue. Which is to run it on KDE Plasma.

I did 2 fresh install on my VirtualBox. One on KDE plasma and the other on LXDE. And I did exactly the same steps. Installing docker and then setting up the Cloudflare tunnel. The one on KDE plasma runs without any issues at all and I’m able to remote access it via the cloudflare tunnel. But the one with LXDE again loses connection once I start the docker run [docker run -d --name cloudflared cloudflare/cloudflared:latest tunnel --no-autoupdate run --token]

Anyone can help or with similar experience? I want to be using LXDE instead of KDE plasma