Cloudflare tunnel with Bastillion

Hi

An easy way to have https accesses to my web services running in my Home server without having to open ports is to use Cloudflare tunnels. This process works with services like Node-RED, InfluxDB, Grafana, etc. but not with Bastillion https://www.bastillion.io a kind of web ssh client.

Note that if I open locally (that is inside the server) the url of Bastillion https://127.0.0.1:8443, all works OK which means that the container is running well.

Do you know what could cause this malfunction?

Regards

You don’t need to open ports to use tunnels, that one of the perks about them. They reach out to Cloudflare’s server and make the connection that way.

1 Like

Hi
But I wrote precisely that: “… web services running in my Home server WITHOUT having to open ports is to use Cloudflare tunnels”!?!
Nevertheless I already solved the problem: during the tunnel creation wizard, I just had to choose in the “Public Hostname Page” a service Type: HTTPS and then in the “Additional application settings” enable the “No TLS Verify” in TLS section.
Regards