Cloudflare Tunnel Service Won't Start - Windows 10

Hello.

I’m trying to install Cloudflare Tunnel as a service on a Windows machine. I’m following step-by-step of this tutorial: https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/run-tunnel/as-a-service/windows/

I’ve done this before in other machines and worked just fine, but for some reason, in this machine, at the end of the process, the service simply won’t start.
When I run

sc start cloudflared tunnel run

It returns some information about the service, but if I check on the services manager, the service is still not running. If I try to start the service manually from the services manager, I get a 1067 error message.

Below is how my folders, my config files and my registry are set up and below it you can see the error I’m getting:

Windows couldn’t start the Cloudflare Tunnel agent service in Local Machine. Error 1067: The process finished unexpectedly.

I’ve been searching for days on how to get around this but still no solution.
My first idea was that there was something wrong with the regestry entry, but I’ve checked multiple times and it seems fine, it’s also the exact same entry I’ve used in my other machines and work fine.

Thanks

I realise that this doesn’t necessarily answer your question but I would recommend moving to the new Cloudflare Tunnel config setup, as detailed here: https://blog.cloudflare.com/ridiculously-easy-to-use-tunnels/

It’s genuinely much simpler to use as you manage the config in the https://dash.teams.cloudflare.com/ portal and on the PC, you just run “cloudflare.exe service install --token 'insert token from portal'” and it manages everything else for you. You don’t even need the cert.pem or json files anymore!

1 Like

Actually you can omit the --config parameter in the ImagePath registry key as long as your config.yml is located inside the C:\Windows\System32\config\systemprofile\.cloudflared.

Anyway, I’ve tried the new Tunnel setup and it’s really easy to use.