Cloudflare Tunnel issues

I am having issues setting up my Cloudflare Tunnel with multiple records , the tunnel is established but I am getting errors.

Good day i have installed the Argo VPN and created the tunnel and everything woks starting up the service, i have installed apache2 and it works just fine but when i hit the URL i am getting this error

2022-02-03T21:10:03Z ERR error=“Unable to reach the origin service. The service may be down or it may not be responding to traffic from cloudflared: dial tcp 127.0.0.1:8 080: connect: connection refused” cfRay=6d7ea4ce396c8bff-MIA originService=http://loc alhost:8080

sudo cloudflared tunnel --config ~/root/.cloudflared/config.yaml run vboxtest

This is in my config.yaml this is just a simple file but i will host multiple hosts.

tunnel: TUNNEL ID credentials-file: /root/.cloudflared/vboxtest.json ingress: - hostname: vtest1.vboxsystems.com service: http://127.0.0.1: 80 service: http_status:404

can you tell me what i am doing wrong?

What does your apache config look it? It is listening on localhost as well as the normal IP?

yes its configure <VirtualHost *:80> and the other is <VirtualHost *:81>

Your config seems off: the error message has originService=http://localhost:8080 while your service is service: http://127.0.0.1:80

so the it should look like this
tunnel: TUNNEL ID
credentials-file: /root/.cloudflared/vboxtest.json
ingress:

What is the point of:

I don’t see that as a config option

Can you try this config:

tunnel: TUNNEL ID
credentials-file: /root/.cloudflared/vboxtest.json
ingress:
    - hostname: vtest1.vboxsystems.com
      service: http://localhost:80
    - hostname: vtest2.vboxsystems.com
      service: http://localhost:81
    - service: http_status:404

this is the config i had before i strip it down , with same error

[email protected]:/home/ubuntu# cloudflared tunnel --config ~/root/.cloudflared/config.yaml run vboxtest
2022-02-08T23:09:11Z INF Starting tunnel tunnelID=
2022-02-08T23:09:11Z INF Cannot determine default configuration path. No file [config.yml config.yaml] in [~/.cloudflared ~/.Cloudflare-warp ~/Cloudflare-warp /etc/cloudflar
ed /usr/local/etc/cloudflared]
2022-02-08T23:09:11Z INF Version 2022.1.3
2022-02-08T23:09:11Z INF GOOS: linux, GOVersion: go1.17.5, GoArch: amd64
2022-02-08T23:09:11Z INF Settings: map[config:/root/root/.cloudflared/config.yaml]
2022-02-08T23:09:11Z INF Generated Connector ID: 4f21bb2f-dec2-4d46-8a7a-55dc86b85c0c
2022-02-08T23:09:11Z INF Initial protocol http2
2022-02-08T23:09:11Z INF cloudflared will not automatically update if installed by a package manager.
2022-02-08T23:09:11Z INF Starting metrics server on 127.0.0.1:37883/metrics
2022-02-08T23:09:11Z WRN Your version 2022.1.3 is outdated. We recommend upgrading it to 2022.2.0
2022-02-08T23:09:11Z INF Connection e6fdc6fc-7692-4e78-b1af-68b1916ab8e6 registered connIndex=0 location=IAD
2022-02-08T23:09:12Z INF Connection 07a37ec1-a4f4-474c-8f4a-226463bc44ca registered connIndex=1 location=IAD
2022-02-08T23:09:12Z INF Connection 7ce80b7f-793d-4bb8-bb2b-e45fe40126c6 registered connIndex=2 location=IAD
2022-02-08T23:09:14Z INF Connection 77efaf42-6a2c-43a5-9f0a-7dca137096dc registered connIndex=3 location=IAD

This log looks fine. What do you see if you run: netstat -anp | grep apache

tcp6 0 0 :::80 :::* LISTEN 11701
/apache2

I am new to Cloudflare so i am seeing if this Cloudflare Tunnel makes sense…

the error seems that the tunnel is not using the config and using the default port and config…
2022-02-08T23:18:36Z ERR error=“Unable to reach the origin service. The service may
be down or it may not be responding to traffic from cloudflared: dial tcp 127.0.0.1:8
080: connect: connection refused” cfRay=6da893fc4ae00329-MIA originService=http://loc
alhost:8080

it i hit the server IP directly the sites comes up.

¡Hola @vparague!

Please provide the plain text outputs of the following:

Have you been successful with Quick Tunnels · Cloudflare Zero Trust docs perhaps?

¡Gracias!