Cloudflare to propagate the DNS records for TXT DKIM record

The domain isn’t verified in Mailgun because the DKIM record that we provided isn’t present in the DNS. I added the TXT record for “krs._domainkey” in Cloudflare and MAilGun says its have to reach out to your domain host for further assistance as it is Cloudflare’s responsibility to propagate DNS records added into their interface into the DNS.

How do I get this to happen?


Hello there,

Make sure the added entry is valid as it is given by Mailgun.

Hi, This is what I copied from Mailgun into Cloudflare for the setup of the TXTrecord for krs._domainkey

k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDPbWd0JCI2x12o4+sdt1eDAvGxq//vIk8Sfge6qaYd6lil7zfNtOvoBQ2ubWNFOmNFSUyzLYmA3YnmUNlSXJc4VOZcN3W4KaAqmmyP8lU6yPL+vEHvhJb5X5Sr6LFARXWvWA0Kga+jHjEa7vZJCtf7dO+xvSxegzB2QqrCmYR7mwIDAQAB

did you copy something else?

It’s still saying “none found” in MAilGun


See pics!

The Mailgun image indicates that it is looking for and you added krs._domainkey. If you use the matching name, Mailgun should find it. Remember that negative results can be cached. This means that once you have the correct record in place, you may need to wait for a query cache to expire at Mailgun.


Thanks! But I didn’t have to add the .mg in my last URL.
So far no verification. I 'll wait a few more minutes.

Thank you! It finally worked. You know more than both MailGun and Cloudflare support after 2 full days of back and forth. I’m not sure how the last domain even worked.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.