Cloudflare Stopped Working From Last Few Days

I have started using cloudflare from last couple of months. I have made all the necessary changes to make cloudflare work for my website. It was working fine for a month and now when I see analytics, I obsesrve that cloudflare has stopped working for my finance website. I was not able to uploaded screenshot of analytics for observation purpose.

Since email was not working. I found answer from cloudflare community and then I have switched off “proxy status” for couple of DNS records. Since then it was working fine as well as email. but suddenly one day, I see that cloudflare doesn’t have anydata and its not working for my website. I have attached my DNS records for reference only.

Also from last few days, I have also noticed that my SSL has also stopped working, which was working good. So for now you can see, is running on LetsEncrypt SSL instead of cloudflare ssl. As http was not redirecting to https, so I have manually added this ssl certificate as cloudflare ssl was not working.

#CommunityTip: There is no error message. but I have noticed that cloudflare has stopped working from last few days. :relieved:

So overall, Now nothing works for me even after all the DNS records are present. I am seeing some help from you guys to resolve my problem. I appreciate your all the efforts to assist me on the same.


You have set everything to :grey:, so you’re bypassing Cloudflare.

For starters, the “A” record for and the CNAME for ‘www’ should be set to :orange:.


Appreciate your help. I will wait for couple of day to check - If I am getting any data in cloudflare analytics.

Just to clarify, this will not impact my emails, right? For emails to work I have set everything to DNS only. Just to confirm - do we just need to set MX - - for proxy status as “DNS only” to make email communication works?

Much Thanks!

I have noticed that after changing the proxy status of DNS record as mentioned. my email id is not working now. Gmail is not able to sync emails from my domain email id. I am getting error message as - Error checking mail for [email protected]. Please check the attached screenshot of changed status of DNS records.

I can see that after changing proxy status of DNS records, pages are been cached and I can see the same in analytics as well as my SSL certificate also updated to cloudflare SSL now.

Kindly assist me, Email not working on email Client after making changes to proxy status of DNS records in cloudflare for my website .

#CommunityTip : Error checking mail for [email protected].

What hostname is your mail client trying to connect to?

My website is hosted at godaddy. This is the attached screenshot for the configuration connection to gmail.

Kindly assist me on the same.

Try changing the Incoming and Outgoing/SMTP servers to mail.EXAMPLE.COM (your domain). The ‘mail’ subdomain is not set to :orange:, so it’s a direct connection. Your EXAMPLE.COM is :orange: and does not proxy email connections.

I have spoken to godaddy for changing outgoing server and incoming server to They mentioned that your email ids will also change when we add subdomain in your linux cpanel hosting. For eg: it will change to [email protected]. I don’t what this way. I want it to remain as [email protected]

Seems like I am stuck in between. Now godaddy are mentioning all the reasons to ask support from cloudflare. As I want to use cloudflare as well as mails both at same time. Please guide me, how can I get back emails working when using cloudflare.

Thanks in advance!

But…your DNS already has an entry for the mail subdomain. Did you add that, or is it also in the DNS page over at GoDaddy?

I believe, I have added after seeing some of the support pages from cloudflare, when I was searching email not working with cloudflare.

In goddady, I don’t see any DNS records. It gives the message that “We can’t display your DNS information because your nameservers aren’t managed by us.”

Can someone assist me on this?

My email has stopped working. Is there any other ways like: email routing, adding mx records, etc to make emails work with cloudflare. As I am not able to change my incoming and outgoing servername.

Also I am looking for any cloudflare support on call or email, if anyone aware of it - let me know. As I am not able to get my answers on cloudflare community.

Try adding a CNAME for ‘mail’ instead of that “A” record. Have it point to your And set that CNAME to :grey:. I think Cloudflare will create a DNS alias that will work for email.

Cloudflare Support ticket system:
Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

When i tried the above method of add a record in cloudflare account. Please find the error which I encountered while adding it.

Kindly assist me on the same.

Get rid of that “A” record for ‘mail’.

Thank you for the information.

I have changed the DNS records in cloudflare as specified and then I have waited for a hour to get propagation.

After sometime, I have checked in email settings in godaddy account. Under Non-SSL setting, I observed that outgoing and incoming server got changed to and also I tried to connect account in gmail through POP3 and I was succesfully in doing so. Thank you much for your assistance.

Thank you Sir, this problem is got partially solved.

Is there possibility that my SSL Setting for incoming and outgoing server - can also get updated to by making any changes or adding records under DNS configuration?

Only your host can fix the SSL certificate for that subdomain, as it’s a direct connection to that server.

But I am currently using cloudflare SSL certificate, won’t this SSL certificate will help?

This topic was automatically closed after 14 days. New replies are no longer allowed.