Cloudflare SSL Problem (I can't figure it out for 2 days.)

Hello There,
I have Cloudflare free plan installed on a Wordpress based website for about 2 years, but recently, SSL problems started to occur on my site. When visitors try to enter my site, it gives a warning as “Your connection is not private “Attackers may be trying to steal your information from www.web site adress.(for example, passwords, messages or credit cards).””.

I tried both Flexible and full options from the SSL panel, but google still gives warnings to visitors when entering my site. How can I solve this problem?

Web site adress: https://www.colaker.net/

Greetings,

Thank you for asking.

Maybe the SSL certificate expired and you need a new one at your origin host/server for your domain name to be re-issued/renewed.

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

However, write back if your WordPress is configured with “home_url” and “site_url” in the “Options” and working fine over a HTTPS in a different Web browser just for testing purposes.

Working fine from my end over HTTPS when it’s paused or unproxied as from what I currently see, meaning SSL is ok. At the SSL tab of Cloudflare dashboard make sure it’s set to Full (Strict) (Strict might not work if you’re using cPanel in some cases, so Full would be ok then).

Otherwise, is the “Always Use HTTPS” in Cloudflare dashboard enabled?. This option is in the Edge Certificates tab of the Cloudflare SSL/TLS tab. Alongside with it, “Automatic HTTPS Rewrites” on this same page can be enabled too.

2 Likes

Hello,

I’ve tried all the methods you said, but I’m still having problems. Now, my site sometimes creates users without any problems, sometimes it gives an ssl error and google gives the warning “Your connection is not private”. In this case, it changes every 2-3 hours. I can’t even access the admin panel of my own site right now.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.