Cloudflare SSL not working on sub domain

#1

Hi All,
I am using clouflare SSL certificate on my website, www.zelaflow.com , and the SSL is working correctly, but the SSL does not working on this subdomain > beta.zelaflow.com ,
although there is a first subdomain and it should be work.
any suggestion.

0 Likes

#2

The domain :wink:

1 Like

#4

Can your share your domain so we can troubleshoot!

1 Like

#5

How should anybody be able to say anything without knowing your domain?

0 Likes

#6

www.zelaflow.com and the subdomain is beta.zelaflow.com

0 Likes

#7

Isnt the error message pretty clear?

image

You need to renew your certificate.

0 Likes

#8

yes it is clear, but there is a misunderstanding for me, the SSL works for main domain , but does not work for first sub domain, should i renew it via crypto page ? in which part ?

0 Likes

#9

You are not proxying that beta record, hence it does not hit Cloudflare but your server directly. Consequently it does not use Cloudflare’s certificate. You can either proxy it and downgrade your security to Full instead of “Full strict” or simply renew your certificate.

I would not advise the former though and recommend to go with the latter approach.

0 Likes

#10

so for renewing , the solution is in Crypto page > edge certificate > upgrade ?

0 Likes

#11

No, you need to renew the certificate on your server. That is completely unrelated to Cloudflare.

0 Likes

#12

This one

image

0 Likes

#13

So I have to renew it by Lets encrypt authority ?

0 Likes

#14

Yes.


0 Likes

#15

Thank you for your response,
Then how can I change SSL Certificate of subdomain that it uses Lets Encrypt to cloudflare SSL Certificate,???
, because the SSL of Cloudflare is working correctly for main domain , and as beta.zelaflow.com is the first subdomain, I want to activate it for subdomain to .

0 Likes

#16

Cloudflare is still not involved here, you need to renew your server certificate.

0 Likes

#17

can you describe more, what do you mean by “Cloudflare is still not involved here”?
so I have to make changes in AWS ( my website hosted in AWS) ?

0 Likes

#18

I can not use cloudflare SSL certificate for beta.zelaflow.com ???

0 Likes

#19

You have a certificate on your server. That certificate has expired. You need to renew that certificate.

Cloudflare has nothing to do with that, unless you have an origin certificate issued by them in which case you’d go to the control panel and have that certificate issued. You will still need to configure it on your server though.

This is all something you need to fix on your server.

0 Likes

closed #20

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes