Cloudflare SSL not applied

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?
Yes, but only saw someone for whom it was fixed by time.

When you tested your domain, what were the results?
Security Warning in the browser because of Certificate from Hosting Provider A2 Hosting being used.

Describe the issue you are having:
I have multiple websites connected to Cloudflare, some of them integrated to Ezoic through Cloudflare.
I compared 2 working domains with this domain having the issues and visually the settings look the same. But for the other 2 domains it works, meaning they use the SSL Certificate from Cloudflare. While for the mentioned domain the Certificate from the Hoster is being used (A2 Hosting).
Despite visually the same Settings for SSL and DNS being applied for the Domain (which is integrated to Ezoic through Cloudflare) all but this domains SSL Certificate is used from Cloudflare, not

What error message or number are you receiving?

Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages or credit cards). Learn more


What steps have you taken to resolve the issue?

  1. Tried enable/disable pass through, no difference.
  2. Removed Ezoic Integration

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. Visit the webite

Have you tried from another browser and/or incognito mode?
Yes, Firefox, Chrome, Safari. Regular and incognito.

Please attach a screenshot of the error:

Your domain appears to load just fine over SSL here or anywhere I have tried - what you’re describing sounds like your local DNS might not be connecting to Cloudflare.

If you still see an SSL error, check how your local machine is connecting to Cloudflare via curl -v - the IP that cURL connects to should be a Cloudflare IP. If it isn’t, something locally is interferring with your connection.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.